где?! урлдекод в статусной строке выводить вместо пруфлинка? ссылку на параграф, пожалуйста.
Я не это имел ввиду.
Также нет стандарта который обязывает отображать вам в браузере все не сырым HTML:)
Но есть стандарт, который дает понимание как HTML надо интерпретировать.
toxic steel:
ага, зато брызжете тут либерализмом, якобы в интересах неопытных пользователей. есть стандарт адресации вебдокументов. иностранный язык сейчас начинают в младших классах учить, вот пускай проверкой домашних заданий у своих чад займутся, заодно вконтакте импортными закорюками научатся набирать...
Займитесь этим, научите всех жить, удачи! :D
_interceptor_ добавил 12.07.2009 в 16:42
Оксиген: Ну да. А завтра Украина введёт собственную систему адресации, на своей мове. Затем белорусы, казахи, молдоване и т.д. Какая проблема? Технически всё осуществимо. Ибо нефиг заходить на молдавские сайты тем, у кого нет молдавской клавиатуры (хотя бы виртуальной). :D
А чем хуже адыгейцы? Даёшь всем народам домены на национальных языках!
И на молдавские и украинские и белорусские зайдете и прочитаете все и url
Не находите, что эти утверждения сколь тождественны, столь и голословны? Почему-то мне кажется, что вы не пошли за чупа-чупсами прочитав это сообщение. С какой-такой радости люди побегут устанавливать новый браузер? Тем более, те самые малограмотные домохозяйки, для которых якобы РФ и вводится.
Деньги не пахнут? Ну да, я уже заметил это. Когда ответить по существу нечего - переходим на личности. ;)
Ну а что еще можно сказать, если есть стандарт, понятно как и в каких ситуациях
приложение должно себя вести? Ну кто-то не знал про стандарт из разработчиков продукта
или поленился реализовать... я не понимаю почему к этому надо относится столь либерально?
Ну и второе, проблема с url не имеет прямого отношения к РФ, мы и сейчас живем
с этой абракадаброй... мне это уже сейчас неудобно поскольку работаю с движком Wiki.
И я не вижу ничего смешного в url вида
хттп://форум.поисковые-системы.рф/просмотр-темы?номер-темы=373860&страница=25 и т.д.
ternet.ru: Нет.
IE8 - не читается, показывает как есть.
Пользуйтесь фаерфоксом.
Пользуйтесь приложениями, которые реализуют стандарты.
ternet.ru:
И вообще - Вы за своими попытками продвинуть эту несчастную РФ уже так увлеклись, что не заметили - сколько геморроя за собой влечет начало её использования.
Тут подняли реальную проблему, я нашел ответ... что вам не нравится?
ternet.ru:
Можно согласиться с тем, что освоение инноваций требует преодоления каких-то несовместимостей и обновления стандартов, однако даже в ходе данной дискуссии выясняется, что введение .РФ просто является неоправданным с точки зрения соотношения новые возможности/новые проблемы, потому что новых пролем возникает недопустимо много.
Нет несовместимостей, нужно просто изучать стандарты, там все есть.
ternet.ru: Уважаемый, да Вы с ума сошли! :)
Причем тут вообще буфер обмена? У него задача элементарная - брать и копировать как есть, а потом отдавать скопированное как было.
Да, я не спорю, если выделить и скопировать текст на веб-странице и потом вставить в Ворд, то она вставится с сохранением форматирования, но какое право буфер обмена-то имеет трогать кодировку текста?! А если я пишу статью о проблемах URL-кодирования и мне нужно вот эту абракадабру с процентиками скопировать для примера? Что тогда?
Вы тут что издеваетесь над нами чтоли?
Возможно, я ошибаюсь с буфером обмена, я не силен в оконных приложениях,
но в любом случае преобразование
делается либо в момент копирования, либо в момент вставки, а скорее всего может
делаться и там и там, но
главное, чтобы вставка делалась в кодировке окружающей текст.
И последний момент наведите, пожалуйста мышку на ссылку ниже:
вот Вам в этот вопрос не стоило бы встревать, с техникой у вас туго.
По всей видимости те же проблемы и у Алексея Барыкина.
RFC2396
Uniform Resource Identifiers (URI): Generic Syntax T. Berners-Lee, R. Fielding, L. Masinter August 1998 ASCII Obsoleted by RFC3986, Updates RFC1808, RFC1738, Updated by RFC2732
Errata
2ternet.ru
Да, верно подмечено, это буфер обмена типа такой умный.
Надо чтобы поменяли алгоритм у буфера обмена,
т.к. достаточно написать то что закодировано в кодировке, окружающей текст.
Или можно подправить алгоритм редактора в котором мы пишем посты.
Проблем логических я тут не вижу. А технически проблема решаема.
_interceptor_: С ссылками действительно есть некоторая беда. Дело в том, что кодировка ссылки считается как кодировка окружающего текста. Если я делаю ссылки на своем сайте, то они будут выглядеть красиво, например, и будут работать, но если я скопирую такую ссылку и вставлю в форум, то ссылка будет выглядеть некрасиво если кодировка форума не совпадает с кодировкой сайта, например, но ссылка будет работать.
Если же я пишу ссылку на русском прямо в строке браузера по-русски, то в какой кодировки мне ее пришлет браузер - не известно, но перебрать кодировки на стороне сервера в общем не представляется трудным.
В общем надо изучить вопрос...
Предварительно решение такое:
Всегда ссылки писать в кодировке соответствующей окружению текста,
никогда ссылки не кодировать, т.е. писать текст ссылки как есть.
При разработке скриптов всегда считать, что придет ссылка в utf-8.
_interceptor_, я просил ссылку на
есть стандарт, который дает понимание как HTML надо интерпретировать
не надо, пожалуйста, ещё раз «не об этом».
http://www.w3.org/TR/REC-html40-971218/html40.txt
http://www.w3.org/TR/html401/
Но ваши все больше развивающиеся желания выходят уже за пределы темы.
в цитате, приведёной Вами, я не вижу повода для безапелляционной замены ие ффом.
IE мог бы более дружественно относится к пользователю и тогда ссылки
на этой странице:
http://ru.wikipedia.org/wiki/Тест
в статусной строке выглядели бы красиво.
Сосите чупа-чупс! а я за них не *переживаю* ;)
Банальное хамство.
пруфлинк на стандарт ...
http://www.rfc-editor.org/rfc/rfc3986.txt
"
When a new URI scheme defines a component that represents textual
data consisting of characters from the Universal Character Set [UCS],
the data should first be encoded as octets according to the UTF-8
character encoding [STD63]; then only those octets that do not
correspond to characters in the unreserved set should be percent-
encoded. For example, the character A would be represented as "A",
the character LATIN CAPITAL LETTER A WITH GRAVE would be represented
as "%C3%80", and the character KATAKANA LETTER A would be represented
as "%E3%82%A2".
"
где?! урлдекод в статусной строке выводить вместо пруфлинка? ссылку на параграф, пожалуйста.
Я не это имел ввиду.
Также нет стандарта который обязывает отображать вам в браузере все не сырым HTML:)
Но есть стандарт, который дает понимание как HTML надо интерпретировать.
ага, зато брызжете тут либерализмом, якобы в интересах неопытных пользователей. есть стандарт адресации вебдокументов. иностранный язык сейчас начинают в младших классах учить, вот пускай проверкой домашних заданий у своих чад займутся, заодно вконтакте импортными закорюками научатся набирать...
Займитесь этим, научите всех жить, удачи! :D
_interceptor_ добавил 12.07.2009 в 16:42
Ну да. А завтра Украина введёт собственную систему адресации, на своей мове. Затем белорусы, казахи, молдоване и т.д. Какая проблема? Технически всё осуществимо. Ибо нефиг заходить на молдавские сайты тем, у кого нет молдавской клавиатуры (хотя бы виртуальной). :D
А чем хуже адыгейцы? Даёшь всем народам домены на национальных языках!
И на молдавские и украинские и белорусские зайдете и прочитаете все и url
и в тексте и в доменном имени.
Изучайте юникод.
Нет.
Сосите чупа-чупс!
Не находите, что эти утверждения сколь тождественны, столь и голословны? Почему-то мне кажется, что вы не пошли за чупа-чупсами прочитав это сообщение. С какой-такой радости люди побегут устанавливать новый браузер? Тем более, те самые малограмотные домохозяйки, для которых якобы РФ и вводится.
Деньги не пахнут? Ну да, я уже заметил это. Когда ответить по существу нечего - переходим на личности. ;)
Ну а что еще можно сказать, если есть стандарт, понятно как и в каких ситуациях
приложение должно себя вести? Ну кто-то не знал про стандарт из разработчиков продукта
или поленился реализовать... я не понимаю почему к этому надо относится столь либерально?
Ну и второе, проблема с url не имеет прямого отношения к РФ, мы и сейчас живем
с этой абракадаброй... мне это уже сейчас неудобно поскольку работаю с движком Wiki.
И я не вижу ничего смешного в url вида
хттп://форум.поисковые-системы.рф/просмотр-темы?номер-темы=373860&страница=25 и т.д.
или такой:
хттп://эльдорадо.рф/каталог/телевизоры/описание-товара/710
Мне нравится такой url, он будет понятен любому неопытному пользователю.
Это называется дружественный интерфейс.
Нет.
IE8 - не читается, показывает как есть.
Пользуйтесь фаерфоксом.
Пользуйтесь приложениями, которые реализуют стандарты.
И вообще - Вы за своими попытками продвинуть эту несчастную РФ уже так увлеклись, что не заметили - сколько геморроя за собой влечет начало её использования.
Тут подняли реальную проблему, я нашел ответ... что вам не нравится?
Можно согласиться с тем, что освоение инноваций требует преодоления каких-то несовместимостей и обновления стандартов, однако даже в ходе данной дискуссии выясняется, что введение .РФ просто является неоправданным с точки зрения соотношения новые возможности/новые проблемы, потому что новых пролем возникает недопустимо много.
Нет несовместимостей, нужно просто изучать стандарты, там все есть.
Нужно просто аккуратно реализовывать стандарты.
Уважаемый, да Вы с ума сошли! :)
Причем тут вообще буфер обмена? У него задача элементарная - брать и копировать как есть, а потом отдавать скопированное как было.
Да, я не спорю, если выделить и скопировать текст на веб-странице и потом вставить в Ворд, то она вставится с сохранением форматирования, но какое право буфер обмена-то имеет трогать кодировку текста?! А если я пишу статью о проблемах URL-кодирования и мне нужно вот эту абракадабру с процентиками скопировать для примера? Что тогда?
Вы тут что издеваетесь над нами чтоли?
Возможно, я ошибаюсь с буфером обмена, я не силен в оконных приложениях,
но в любом случае преобразование
делается либо в момент копирования, либо в момент вставки, а скорее всего может
делаться и там и там, но
главное, чтобы вставка делалась в кодировке окружающей текст.
И последний момент наведите, пожалуйста мышку на ссылку ниже:
http://ru.wikipedia.org/wiki/%D0%A2%D0%B5%D1%81%D1%82
Читается, да?:)
Вот конкретно этот редактор мог бы делать немного больше работы после того как определил
что-то похожее на ссылку и делал ей правильный, красивый текст.
2pistol судя по rfc какраз преобразование в utf, а затем побайтное кодирование обязательно,
если я правильно понял эту опцию.
2Оксиген
вот Вам в этот вопрос не стоило бы встревать, с техникой у вас туго.
По всей видимости те же проблемы и у Алексея Барыкина.
RFC2396
Uniform Resource Identifiers (URI): Generic Syntax T. Berners-Lee, R. Fielding, L. Masinter August 1998 ASCII Obsoleted by RFC3986, Updates RFC1808, RFC1738, Updated by RFC2732
Errata
2ternet.ru
Да, верно подмечено, это буфер обмена типа такой умный.
Надо чтобы поменяли алгоритм у буфера обмена,
т.к. достаточно написать то что закодировано в кодировке, окружающей текст.
Или можно подправить алгоритм редактора в котором мы пишем посты.
Проблем логических я тут не вижу. А технически проблема решаема.
С ссылками действительно есть некоторая беда.
Дело в том, что кодировка ссылки считается как кодировка окружающего текста.
Если я делаю ссылки на своем сайте, то они будут выглядеть красиво, например, и будут
работать, но если я скопирую такую ссылку и вставлю в форум, то ссылка будет выглядеть некрасиво если кодировка форума не совпадает с кодировкой сайта, например, но ссылка будет работать.
Если же я пишу ссылку на русском прямо в строке браузера по-русски, то в какой
кодировки мне ее пришлет браузер - не известно, но перебрать кодировки на стороне сервера в общем не представляется трудным.
В общем надо изучить вопрос...
Предварительно решение такое:
Всегда ссылки писать в кодировке соответствующей окружению текста,
никогда ссылки не кодировать, т.е. писать текст ссылки как есть.
При разработке скриптов всегда считать, что придет ссылка в utf-8.
Все это вытекает из стандарта
http://www.rfc-editor.org/rfc/rfc3986.txt
"
...
When a new URI scheme defines a component that represents textual
data consisting of characters from the Universal Character Set [UCS],
the data should first be encoded as octets according to the UTF-8
character encoding [STD63]; then only those octets that do not
correspond to characters in the unreserved set should be percent-
encoded. For example, the character A would be represented as "A",
the character LATIN CAPITAL LETTER A WITH GRAVE would be represented
as "%C3%80", and the character KATAKANA LETTER A would be represented
as "%E3%82%A2".
...
"
Весь url можно писать на русском без проблем.
И в тексте и на форумах все будет выглядеть красиво и правильно и при вбивании url ручками в браузер.
PROMEXPRESS.RU
100005$
Интересно, неужели РуЦентр выставит этот домен на открытый с такой же стартовой или всё же как-то домен переоценит?
http://auction.nic.ru/torgi/lot.cgi?id=45873
По-моему они в таких ситуациях сильно долго не думают:
PROMEXPRESS.RU
ТОРГИ НЕ НАЧАТЫ
ТИП АУКЦИОНА:
аукцион доменов
СТАРТОВАЯ ЦЕНА:
10 000 у.е.
ШАГ АУКЦИОНА:
20 - 50 у.е.
БЛИЦ-ЦЕНА:
не установлена
НАЧАЛО ТОРГОВ:
12.07.2009 06:35
ОКОНЧАНИЕ ТОРГОВ:
04.08.2009 16:50
Хотя я в этом домене не вижу ничего и на 100$
После ввода .рф вам (любителям кириллицы) предстоит изучить еще много таких подобных вопросов :)
А мы не боимся трудностей.
Трудности - это возможность заработать денег, если решить их первыми.