Нормально если вебмастер сделал сайт на wordpress, работающий только на PHP 5.6?

-O
На сайте с 16.08.2019
Offline
0
3704

Здравствуйте, коллеги,

попрошу вас высказать своё мнение по поводу одной спорной ситуации

Я - сис. админ хостинга. Одному из моих клиентов вебмастер сделал сайт на wordpress, работающий только на PHP 5.6 (я это проверил, но выяснилось это уже после 100% оплаты за работу, это было около 40 тыс. руб). На более свежих версиях PHP (7.1, 7.2), сайт работать отказывается, выдавая ошибку (все подробности ниже). Для того, чтобы сайт заработал, этот вебмастер потребовал еще 25 тыс. руб. Насколько вы считаете эту ситуацию нормальной?

Подробности:

Вот наша переписка

...

Сис. админ. Олег:

Здравствуйте, Алексей,

установил сайт на два разных хостинга (****) , на каждом из них сайт не работает. Подозреваю, что из-за более старой версии php, использующейся у вас на локали ...

Вот ошибка:

# tail -1 /home/new/logs/error_log

[Sat Aug 10 22:35:33.472507 2019] [proxy_fcgi:error] [pid 24905] [client 60598] AH01071: Got error 'PHP message: PHP Parse error: syntax error, unexpected '}', expecting end of file in /home/new/public_html/wp-content/themes/travelwithme/asstes/widget-social.php on line 77\n'

на втором хостинге тоже самое

Админка работает и полагаю, что проблема здесь ****

Вебмастер Алексей:

Здесь вопрос не в старосте версии, а том чтобы настроить и синхронизировать версии PHP на хостинге под сайт , обычно так делается, у меня же на хостинге всё работает)))

Сис. админ. Олег:

Алексей,

что вы предлагаете мне сделать под словами "настроить и синхронизировать версии PHP" ???

Какая версия PHP у вас используется?

Вот ошибка: ***

Что вы мне предлагаете с ней делать?????

Вебмастер Алексей:

Сожалею, но я увы не владею необходимыми знаниями, и потому в подобных случаях я обращаюсь за помощью к провайдеру хостинга , которые всегда быстро и качественно решают любую проблему! Поэтому если в данном случае Вы обязались выступать в роли технической поддержки сервера, то видимо это нужно и разбираться именно Вам!

Сис. админ. Олег:

Алексей, повторяю свой вопрос, какая версия PHP на вашем хостинге?

Вебмастер Алексей:

Совершенно не в курсе((

Сис. админ. Олег:

Придётся вам помочь, у вас стоит версия PHP 5.6.36

Она устарела, имеет проблемы с безопасностью и давно не поддерживается: https://www.php.net/supported-versions.php

Использование такой версии PHP на хостинге не приемлемо.

Новые версии PHP не поддерживают некоторые потенциально небезопасные функции, откуда часто и возникают ошибки "PHP Parse error:

syntax error, unexpected"

Вебмастер Алексей:

На сегодняшний день версия PHP 5.6.36 является вполне современной и соответствующей всем требованием безопасности! Ну если Вы так сильно хотите, то пожалуйста согласовывайте это с Игорем, так как увы но эта работа будет платной и весьма не дешевой что-то около 25 000 р. так как придется подтягивать программиста и программить сайт, как говорится любой каприз))) Но мне кажется гораздо проще сделать на вашем сервере данную версию доступной для использования

Сис. админ. Олег:

Алексей,

еще раз, вот официальный сайт PHP

https://www.php.net/supported-versions.php

Специально для вас расшифровываю, PHP 5.6 не обновляется 1 января 2017 года, а с 1 января 2019 вообще не поддерживается, уже 8 месяцев не выходят даже обновления безопасности, вы вообще понимаете то, о чем пишете и что вообще предлагаете????

Вы хотите чтобы сайт был уязвим и создавал потенциальную брешь в безопасности сервера???

О каком капризе вообще идет речь если эксплуатация сайта в таком виде просто небезопасна???

Если завтра выпустят эксплойт, легко ломающий все сайты на этой версии, то сайт только срочно выключать, без вариантов...и такое бывало много раз, за 19 лет моей работы...

Я считая, что в августе 2019 сделать сайт, не работающий на версии PHP 7.2 и предложить его допилить за 25000 для того, чтобы он работал - это просто верх непрофессионализма.

Я просто в шоке.

Вебмастер Алексей:

Да и на всякий случай: на сегодняшний день в интернете более 98 % сайтов работают на 5-й и еще более ранних версиях PHP и процесс перехода на новый 7-е весьма длителен! И Порядок вещей таков: что именно хостеры настраивают свой софт под сайт и никак не наоборот!)))

Сис. админ. Олег:

Категорически не согласен с вами.

Кроме того, если какие-то сайты и работают на 5 версии, то это только потому, что были сделаны много-много лет назад, а их владельцы ждут, пока их взломают,

но уж сайт, сделанный в августе 2019 и не работающий на PHP 7.2 - это просто нонсенс!!!

Вебмастер Алексей:

Уважаемый! А я считаю верхом непрофессионализма не разбираться в сайтостроении и при этом пытаться что-то доказывать! А Вы вообще понимаете почему на сегодняшний день огромное количество сайтов делаются еще на 5 PHP?

А почему при переходе на 7 многие компоненты сайта не работают?

Почему все хостеры полностью поддерживают версию PHP 5.6? А вот кстати с 7-кой бывают проблемы?

И почему все переходы версий PHP растягиваются на 3-5 лет?

Я в шоке от Вас что Вам просто лень или опять отсутствие профессиональных знаний УЖЕ ВТОРОЙ МЕСЯЦ мешают установить готовый и работающий сайт на сервере!!!

ЗА 12 лет практики я впервые столкнулся с таким дилетантским отношением!!!

Отсюда вывод:

1. Вы абсолютно не понимаете сути вопроса!

2. Пытаетесь решить свои проблемы чужими руками.

3. Допускаете в адрес оппонента не корректные выпады!

На основании всего вышеизложенного и опираясь на то что я передал заказчику сайт в полной готовности и работоспособности, а также в связи с полным отсутствием желания решать свои проблемы со стороны представителя заказчика, я далее прекращаю всяческие рассуждения на эту тему. Так как не вижу смысла убеждать Вас в том чего Вы не желаете понять!

Удачи Вам юноша и более не пишите на этот адрес!

Сис. админ. Олег:

Найдите одну, только хотя бы одну единственную веб-студию (ну кроме вас, конечно :))), которая создает сайты, не работающие на 7.2 PHP !!!

И опыта у меня побольше вашего лет так этак на 10 как минимум.... даже если предположить что у вас 12 лет практики :)))

А ваша фраза, как веб-мастера, что вы "Совершенно не в курсе((" на какой версии PHP у вас работает сайт, при декларируемых 12 годах практики просто .... обескураживает ( выражусь мягко ;)

...

В декабре 2019 года разработчики wordpress планируют отказаться от поддержки php 5.6

...

Дальше Вебмастер Алексей не отвечает

SeVlad
На сайте с 03.11.2008
Offline
1462
#1
--Oleg--:
Нормально если вебмастер сделал сайт на wordpress, работающий только на PHP 5.6?

В целом нет. (могут временные исключения, который правильный вебмастер устранит в ближайшем будущем).

Я всю портянку не осилил (нафига нам ваша переписка), но судя по ошибкеиспользуется вот эта тема,только древняя воровання с помойки.

Чем это грозит конечному клиенту см https://codex.wordpress.org/%D0%A7%D0%90%D0%92%D0%9E/%D0%A1%D0%B0%D0%B9%D1%82_%D0%B2%D0%B7%D0%BB%D0%BE%D0%BC%D0%B0%D0%BB%D0%B8.

Либо кривой самапал.

ЗЫ. В см - подозреваю что ворованная. Актуальная версия 2.7.5. Используемую можно увидеть в начале файла /home/new/public_html/wp-content/themes/travelwithme/style.css

ЗЫ2. Уппс.. Не не эта тема. Сорри.. Но производителя можно увидеть всё в том же style.css (если это "вебмастер" не положил ещё большую свинью, отредактировав эти заголовки) и там уже поискать актуальную версию. Если таковая существует.

Делаю хорошие сайты хорошим людям. Предпочтение коммерческим направлениям. Топики помощи с ⓌordPress (https://searchengines.guru/ru/forum/1032910 ) и основы безопасности сайтов ( https://searchengines.guru/ru/forum/774117 ). *** Помощь\консультации в топиках форума - БЕСПЛАТНО. Платные услуги ( https://wp.me/P3YHjQ-3 ) - с бюджетом от 150$ ***
LEOnidUKG
На сайте с 25.11.2006
Offline
1590
#2

Мухахах. Вебмастер тему установил битую и старую, где некоторые функции работают только на PHP 5.6.

Переписать их можно, но заплатили ли за это?

В ТЗ условия не было про PHP7? Тогда к чему вопросы.

---------- Добавлено 16.08.2019 в 13:59 ----------

этот вебмастер потребовал еще 25 тыс. руб

За пол цены могу посмотреть, что у вас там :)

✅ Трастовых площадок под размещение статей и ссылок. Опыт 12 лет! ( https://searchengines.guru/ru/forum/675690 ) ⭐ Купить вечные трастовые ссылки для сайта ( https://getmanylinks.ru/?srh ) ⭐ Ускорение ваших сайтов (WP, Opencart и др.) + Настройка сервера ( https://searchengines.guru/ru/forum/997205 )
SeVlad
На сайте с 03.11.2008
Offline
1462
#3
LEOnidUKG:
В ТЗ условия не было про PHP7? Тогда к чему вопросы.

Может ещё в ТЗ надо указывать, чтобы сайт отображался в современном браузере? А работал в современном интернете - не надо?

Во-первых 5,6 уже мертв. Во-вторых у каждого нормального движка (и у ВП в тч) есть требования/рекомендации к ПО сервера.

LEOnidUKG
На сайте с 25.11.2006
Offline
1590
#4
Может ещё в ТЗ надо указывать

Всё надо указывать. Если не указанно, то на усмотрение сторон.

edogs software
На сайте с 15.12.2005
Offline
741
#5

--Oleg--,

В этой переписке великолепно всё.

Вебмастер пишущий так, что на 7-ке оно не заводится, это еще суметь надо.

Сисадмин неспособный поставить 5.6, и поэтому заверяющий что все старые версии дырявые насквозь, но вряд ли могущий взломать что-то даже на 4-ке.

Заказчик который не оговорил на чем должен работать результат, не сказавший даже что результат должен работать на его хостинге.

Накосячили - буквально все.

В принципе, надо смотреть изначальную договоренность, а не переписку после. Т.к. не зная о чем и как изначально договаривались - невозможно судить о ситуации. Может договаривались так или иначе в контексте использования именно той версии WP.

По ситуации - мы бы на месте заказчика апеллировали к тому, что сделанная работа должна работать на хостинге заказчика. Не говоря про версии и прочую ерунду. Это вполне логичное требование, что результат работы должен запускаться на хостинге заказчика без дополнительных телодвижений.

Если в изначальной договоренности это по той или иной причине не подразумевалось, то заказчику логично заплатить каких-то денег, но никак не 25к (учитывая стоимость всех работ в 40к), т.к. ситуация с необходимостью запускать на 7.х достаточно прогнозируемая и вебмастер должен был как минимум уточнить этот вполне очевидный момент у заказчика, перед тем как затачиваться на 5.6.

---------- Добавлено 16.08.2019 в 14:09 ----------

SeVlad:
Может ещё в ТЗ надо указывать, чтобы сайт отображался в современном браузере? А работал в современном интернете - не надо?
Неплохо бы. А иногда бывают ситуации, когда надо что бы сайт нормально отображался в ИЕ 6.0, а вот в последних по фиг.
SeVlad:
Во-первых 5,6 уже мертв. Во-вторых у каждого нормального движка (и у ВП в тч) есть требования/рекомендации к ПО сервера.

Не мертв, а снят с поддержки и обновлений. А если в изначальном ТЗ, например, упоминались плагины работающие только под 5.6 и при этом версия пхп на сервере не была оговорена, то по большому счету вебмастер не виноват что сделал под 5.6.

Иногда бывают случаи когда заказчик приходит и говорит, мне надо мол на вордпрессе 2.0 сайт. В чем тогда претензия будет, если он на 7.х пхп не заводится? Надо смотреть изначальное ТЗ, без вариантов.

Разработка крупных и средних проектов. Можно с криптой. Разумные цены. Хорошее качество. Адекватный подход.
SeVlad
На сайте с 03.11.2008
Offline
1462
#6
LEOnidUKG:
Всё надо указывать. Если не указанно, то на усмотрение сторон.

Ага, обязательно надо написать, что бы сайт был в интернете..

Не запаришься ли читать всю эту ересь? (Ещё отдельный вопрос - кто будет писать/платить за эту ненужную хрень)

Есть "требования по умолчанию". И "современное ПО" входит в эти требования. Вот если надо что-то отличное от умолчаний - тогда это надо прописывать.

---------- Добавлено 16.08.2019 в 14:12 ----------

edogs:
перед тем как затачиваться на 5.6.

Он не "затачивался". Он просто подобрал тему на помойке.

---------- Добавлено 16.08.2019 в 14:14 ----------

Ида. Данный вопрос не возник бы в принципе, если бы сайт делал нормальный вебмастер: всё актуальные темы ВП поддерживают 7ку.

---------- Добавлено 16.08.2019 в 14:22 ----------

edogs:
Не мертв, а снят с поддержки и обновлений.

Ленин тоже не мертв, а просто остыл и не двигается :)

Я тебе открою секрет: ПО, снятое с поддержки и обновлений называется "мёртвое".

IL
На сайте с 20.04.2007
Offline
418
#7
SeVlad:
Есть "требования по умолчанию". И "современное ПО" входит в эти требования.

Не соглашусь.. Нет умолчаний. Более того, встречался с тем, что требуется обратная совместимость.. (про IE6 уже упоминалось..)

И да.. куча хостингов поддерживает 5.* версии (в том числе и 5.2, поскольку с 5.3 пошло-поехало.. ))) более того, поддержка нескольких версий PHP в рамках одного аккаунта - это "обычная практика".

И да, версии обновляются и "дыры латаются".. и на 5.2 в том числе.

edogs:
логично заплатить каких-то денег, но никак не 25к (учитывая стоимость всех работ в 40к),

Если откинуть WP и несовместимость в пределах темы.. то "переделать под новую версию языка" может быть вполне сравнимо по стоимости с проектом ))

---------- Добавлено 16.08.2019 в 14:29 ----------

--Oleg--:
Использование такой версии PHP на хостинге не приемлемо.

Угу.. а мужики-то не знали.. ) В соседнем разделе практически у каждого (если не у каждого) можно взять хостинг с 5.6

И да, если это считается не безопасным, то (если нет средств на "переделывать") как вариант (хотя бы временный, для того, чтобы спустя месяц (с) "разместить готовый проект") взять под проект отдельную площадку (без соседей), настроить бэкапы.. и в случае взлома обозначить владельцу сайта ситуацию (Естественно, заранее предупредить и согласовать с ним все риски))

... :) Облачные серверы от RegRu - промокод 3F85-3D10-806D-7224 ( http://levik.info/regru )
suffix
На сайте с 26.08.2010
Offline
277
#8
SeVlad:

Ленин тоже не мертв

Ленин жил, Ленин жив, Ленин будет жить !

По теме:

Вебмастер неправ конечно, но заставить его переделать или вернуть часть денег не получится по закону.

Клуб любителей хрюш (https://www.babai.ru)
IL
На сайте с 20.04.2007
Offline
418
#9

p.s. по сравнению с дырами в устаревших версиях (последних в "ветке") PHP (а также в более-менее популярных современных CMS) гораздо большую опасность представляют "кривые скрипты" (плагины/модули), написанные разработчиками..

_
На сайте с 24.03.2008
Offline
357
#10
--Oleg--:

Дальше Вебмастер Алексей не отвечает

И в целом правильно делает.

Требование к ресурсам - это одно из немногого, что в любом случае имеет смысл формализовать.

Если этого не было сделано, то капризы типа "хочется только на семерке" - это действительно капризы.

И реализация их когда всё уже сделано действительно будет стоить бабок.

Да, всё новое лучше-бы делать на семерке, по-возможности. Логикак в этом есть.

Но до сих пор существует достаточно проектов на 5х версиях, и никаких проблем связанных со взломами итп они не испытывают. И никто не будет их скорее всего переделывать никогда. И лет 10-20 они еще в таком виде как минимум проработают.

ЗЫ. Из двух десятков разнородных проектов на 7ке взлетел без особых проблем только один.

По другим доделки-переделки - десятки-сотни[-тысячи] часов работы "на проект".

Авторизуйтесь или зарегистрируйтесь, чтобы оставить комментарий