Вернуться   Форум об интернет-маркетинге > >
Ответ
 
Опции темы
Старый 08.11.2018, 13:10   #1
Профессор
 
Регистрация: 09.07.2011
Сообщений: 691
Репутация: 27246
Отправить сообщение для SeraZwer с помощью Skype™

По умолчанию WordPress. Обновление PHP до последней версии и проблемы с плагинами (RusToLat)

Для WordPress нужно обновлять PHP до последней версии. Новость - https://www.searchengines.ru/php-wp.html

В настройках хостинга для одного сайта выставил PHP 7.2.10 (есть еще 7.3.0RC2, но ее не пробовал включать). Сам WordPress отлично работает на последней версии PHP. Но вот плагины...

Сразу появилась ошибка, связанная с популярным плагином RusToLat. Старый он уже. Везде на сайте выводится такая строчка:
Цитата:
Warning: count(): Parameter must be an array or an object that implements Countable in .../wp-content/plugins/rustolat/rus-to-lat.php on line 1103
Вопрос: каким плагином можно заменить RusToLat, чтобы он не заменил УРЛы старых записей? Есть еще Cyr-To-Lat и Cyr to Lat enhanced. Но они вроде как меняют старые УРЛы сразу после установки. Может кто-то уже менял? Подскажите, пожалуйста.

Еще по теме: плагином PHP Compatibility Checker можно просканировать тему и все плагины на совместимость с PHP 7.2.

Для RusToLat – Warnings: 1. По идеи, все должно работать. А для WP No External Links - Errors: 15. Его, походу, так же нужно чем-то заменить. Хоть и обновлялся он не так давно. Возможно, разработчики WP No External Links выпустят обновление.

Весело живем Чувствую, придется попотеть с этими старыми плагинами.
SeraZwer вне форума   Ответить с цитированием

Реклама
Старый 08.11.2018, 13:16   #2
-Seller-
Профессор
 
Аватар для -Seller-
 
Регистрация: 31.08.2008
Сообщений: 848
Репутация: 35175

По умолчанию Re: WordPress. Обновление PHP до последней версии и проблемы с плагинами (RusToLat)

А если PHP не обновлять, то старые плагины (RusToLat) будут работать как и прежде, но просто уровень безопасности снизится или еще что-то будет?
-Seller- вне форума   Ответить с цитированием
Старый 08.11.2018, 13:19   #3
LEOnidUKG
『 Работаем 』
 
Аватар для LEOnidUKG
 
Регистрация: 25.11.2006
Адрес: Интернет
Сообщений: 22,774
Репутация: 1994476
Отправить сообщение для LEOnidUKG с помощью ICQ

По умолчанию Re: WordPress. Обновление PHP до последней версии и проблемы с плагинами (RusToLat)

Скачал плагин: https://ru.wordpress.org/plugins/rustolat/

Там нет 1103 строк.
LEOnidUKG на форуме   Ответить с цитированием
Старый 08.11.2018, 13:27   #4
SeraZwer
Профессор
 
Регистрация: 09.07.2011
Сообщений: 691
Репутация: 27246
Отправить сообщение для SeraZwer с помощью Skype™

ТопикСтартер Re: WordPress. Обновление PHP до последней версии и проблемы с плагинами (RusToLat)

Цитата:
Сообщение от -Seller- Посмотреть сообщение
А если PHP не обновлять, то старые плагины (RusToLat) будут работать как и прежде, но просто уровень безопасности снизится или еще что-то будет?
WordPress перестанет получать обновления безопасности.
Цитата:
Сообщение от LEOnidUKG Посмотреть сообщение
Скачал плагин: https://ru.wordpress.org/plugins/rustolat/

Там нет 1103 строк.
Спасибо! Скачал плагин по ссылке, перезаписал, активировал и все работает! Ошибки нет.
Что же это получается, у меня какой-то неправильный RusToLat был установлен?
SeraZwer вне форума   Ответить с цитированием
Старый 08.11.2018, 13:28   #5
LEOnidUKG
『 Работаем 』
 
Аватар для LEOnidUKG
 
Регистрация: 25.11.2006
Адрес: Интернет
Сообщений: 22,774
Репутация: 1994476
Отправить сообщение для LEOnidUKG с помощью ICQ

По умолчанию Re: WordPress. Обновление PHP до последней версии и проблемы с плагинами (RusToLat)

Цитата:
Что же это получается, у меня какой-то неправильный RusToLat был установлен?
нам то откуда знать, что у вас там было?
LEOnidUKG на форуме   Ответить с цитированием
Старый 08.11.2018, 13:32   #6
SeraZwer
Профессор
 
Регистрация: 09.07.2011
Сообщений: 691
Репутация: 27246
Отправить сообщение для SeraZwer с помощью Skype™

ТопикСтартер Re: WordPress. Обновление PHP до последней версии и проблемы с плагинами (RusToLat)

PHP Compatibility Checker выдал 15 ошибок для WP No External Links, но он вроде как работает. Никаких проблем пока не заметил.
SeraZwer вне форума   Ответить с цитированием
Старый 08.11.2018, 13:42   #7
LEOnidUKG
『 Работаем 』
 
Аватар для LEOnidUKG
 
Регистрация: 25.11.2006
Адрес: Интернет
Сообщений: 22,774
Репутация: 1994476
Отправить сообщение для LEOnidUKG с помощью ICQ

По умолчанию Re: WordPress. Обновление PHP до последней версии и проблемы с плагинами (RusToLat)

Исправлять руками или искать другой плагин.
LEOnidUKG на форуме   Ответить с цитированием
Старый 08.11.2018, 14:42   #8
melkozaur
Избранный Адсенсом
 
Аватар для melkozaur
 
Регистрация: 07.04.2010
Адрес: Москва
Сообщений: 7,531
Репутация: 1096177

По умолчанию Re: WordPress. Обновление PHP до последней версии и проблемы с плагинами (RusToLat)

RusToLat устарел, все остальные тоже не очень новые, но работают.
Проблема в том, что у них разные системы замены символов.
melkozaur на форуме   Ответить с цитированием
Старый 08.11.2018, 15:15   #9
SeVlad
Guru-Editor
 
Регистрация: 03.11.2008
Адрес: Donbass
Сообщений: 18,094
Репутация: 1497286

По умолчанию Re: WordPress. Обновление PHP до последней версии и проблемы с плагинами (RusToLat)

Цитата:
Сообщение от -Seller- Посмотреть сообщение
А если PHP не обновлять, то старые плагины (RusToLat) будут работать как и прежде, но просто уровень безопасности снизится
Да. См http://php.net/supported-versions.php

Но это не мешает некоторым и сейчас держать сайты на <5,6 (даже на 5,2) и ловить вири в 1103 строках при всего 103

Цитата:
Сообщение от SeraZwer Посмотреть сообщение
WordPress перестанет получать обновления безопасности.
Не мели чушь.

Цитата:
Сообщение от SeraZwer Посмотреть сообщение
Что же это получается, у меня какой-то неправильный RusToLat был установлен?
Получается что вирь у тебя преспокойно жил.

Цитата:
Сообщение от melkozaur Посмотреть сообщение
RusToLat устарел, все остальные тоже не очень новые, но работают.
Проблема в том, что у них разные системы замены символов.
Ещё они по разному работают.
Напр RusToLat не трогает старые слаги (в см не транслитерирует), у cyr2lat есть проблемы с нек сочетаниями символов, а cyr3lat меняет слаги и вложений.

Но это всё фигня... Цирк начнётся через 10 дней.
__________________
Делаю хорошие сайты хорошим людям. Предпочтение коммерческим направлениям.
Топики помощи с ⓌordPress и основы безопасности сайтов.
*** Помощь\консультации в топиках форума - БЕСПЛАТНО. Через личку - с бюджетом от 150$ ***

Последний раз редактировалось SeVlad; 08.11.2018 в 15:26.. Причина: уточнение по RusToLat
SeVlad на форуме   Ответить с цитированием
Старый 08.11.2018, 15:23   #10
LEOnidUKG
『 Работаем 』
 
Аватар для LEOnidUKG
 
Регистрация: 25.11.2006
Адрес: Интернет
Сообщений: 22,774
Репутация: 1994476
Отправить сообщение для LEOnidUKG с помощью ICQ

По умолчанию Re: WordPress. Обновление PHP до последней версии и проблемы с плагинами (RusToLat)

Цитата:
WordPress перестанет получать обновления безопасности.
Там речь, что старые версии PHP перестанут обновляться.

Я вообще не понимаю, к чему там WP привязали, если речь идёт про все сайты, которые работают на старых версиях PHP. Но копирайтеры такие копирайтеры.
LEOnidUKG на форуме   Ответить с цитированием
Сказали спасибо 2 пользователей:
Ответ

Метки
php , wordpress , плагины



Опции темы

Быстрый переход


Регистрация Справка Календарь Поддержка Все разделы прочитаны