В phpinfo(); строчка Configure Command отвечает за то с какими опциями собирался пакет?

12
Dmitriy_2014
На сайте с 01.07.2014
Offline
124
1239

Всем привет!

Если посмотреть выводимую информацию функцией phpinfo(); то там в строке Configure Command можно увидеть множество опций с которыми собирался пакет при установке в систему, правильно ли я это понимаю.

Ну и вопрос в том, можно ли копирнуть это и так же собрать более новую версию, но в другую папку --prefix=/opt/php/7.2, скажем была версия 7.2.3, а захотелось мне 7.3.17 и в папку другую --prefix=/opt/php/7.3.

Можно ли с теми же параметрами запустить ./configure или под новую версию старые опции могут не подойти.

Заранее всем спасибо за ответы!

lonelywoolf
На сайте с 23.12.2013
Offline
151
#1
Dmitriy_2014:
правильно ли я это понимаю.

Правильно.

Dmitriy_2014:
Можно ли

Можно

Dmitriy_2014:
под новую версию старые опции могут не подойти.

Ну так документацию прочитать бы следует... Там все опции и что они делают - описаны.

Платный и бесплатный хостинг с защитой от DDoS (http://aquinas.su)
M
На сайте с 17.09.2016
Offline
86
#2

./configure --help

Dmitriy_2014
На сайте с 01.07.2014
Offline
124
#3

Да действительно в графе Configure Command были опции с которыми был собран и установлен PHP. И эти опции можно без проблем скопирнуть и использовать для установки новой версии.

Я бы почитал документацию об опциях, но я ленивый вебмастер, тем более их там штук 50, мне бы просто один в один и чтобы заработало. Версии программы не слишком разные по идеи должно быть тоже самое.

Но все же были мелкие проблемки…

configure: WARNING: unrecognized options: --enable-gd-native-ttf, --with-mcrypt

--with-mcrypt – Пришлось удалить из команды кофигурирования, какая-то устаревшая и удаленная в PHP 7.2.0 фигня:

https://www.php.net/manual/ru/intro.mcrypt.php

--enable-gd-native-ttf – Тоже непонятная фигня которая игнорируется с PHP 5.5.0 и удалена в PHP 7.2.0, я её тоже убрал.

https://www.php.net/manual/ru/image.installation.php

configure: WARNING: This bison version is not supported for regeneration of the Zend/PHP parsers (found: none, min: 204, excluded: ).

Ей нужен был какой-то бизон, пришлось установить:

https://ru.wikipedia.org/wiki/GNU_Bison

configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.

Re2c – еще какая-то непонятная фигня к которой на русском даже описания на википедии нет, но устанавливается.

https://en.wikipedia.org/wiki/Re2c

Это все что было в предупреждениях типа WARNING, на которые как я понимаю можно забить.

Но самое страшное это error:

checking for libzip... configure: error: system libzip must be upgraded to version >= 0.11

И в общем то эта библиотека была установлена, но версия не та, а ей нужна так, а той нет и короче я не стал заморачиваться и убрал поддержку ZIP.

И вот вопрос нужна ли вообще поддержка ZIP для сайта на вордпресс, единственное место где я видел работу zip и то я не уверен что это делает PHP это phpMyAdmin когда базу сохраняешь там можно выбрать сжатие tar.gz или zip, но это не точно.

Как это не странно, но make компиляция походу прошла успешно, и пакет установился в новую папку куда префикс был ему задан после make install.

И как это не странно новое приложение выдало по команде ./php --versoin из нового каталога свою версию, а это возможно значит что походу все работает, кроме zip’а.

Ответьте нужен ли ZIP в PHP?

Евгений Крупченко
На сайте с 27.09.2003
Offline
153
#4

вообще-то mcrypt и gd-native-ttf уже и в 7.2 нету.

вы видели результат сборки 7.2 с этими опциями? :) там те же сообщения были скорей всего.

по остальному - да, не только php обновляются, но и куча сопутствующих библиотек, с которыми связаны модули php.

выхода лишь два - не использовать модуль если нет нужной ему библиотеки.

либо поддерживать еще и зоопарк всех зависимостей. и плюс уметь заставлять все части быть связанными именно с нужными версиями других частей.

и это лишь переход у вас от 7.2 к 7.3

а поддерживать полностью функциональными со всеми модулями все от 5.3 до 7.4 скажем... это та еще веселуха. проходил через это. но все реально, нет ничего невозможного. надо лишь понять что с чем связано и от каких максимальных/минимальных версий зависит.

нужен ли zip в php никто кроме вас не скажет. кому-то вообще ни один доп. модуль php не нужен, а каким-то cms с тучей плагинов нужны чуть ли не все существующие.

просто пробуйте, если будут ошибки типа нет такой-то функции, значит скорей всего нет модуля, в которой эта функция находится.

Dmitriy_2014
На сайте с 01.07.2014
Offline
124
#5
EvGenius:
вообще-то mcrypt и gd-native-ttf уже и в 7.2 нету.
вы видели результат сборки 7.2 с этими опциями? :) там те же сообщения были скорей всего.

Нет не видел, т.к. ту версию мне помогла установить техническая поддержка хостинга, я поэтому и подумал, что если скопировать те опции, с которыми они устанавливали то также и установится новая версия, в целом так и получилось за исключением пары предупреждений и одной ошибки.

Dmitriy_2014
На сайте с 01.07.2014
Offline
124
#6

Это невероятно, но моя скомпилированная версия работает, не только показывая версию PHP по команде - ./php –version, но и в работе с сайтом, но к сожалению, она не принесла ускорение в 100ms, а более того один из плагинов сразу убил работу сайта в хлам, в Состояние здоровья сайта появились новые рекомендации:

Рекомендуемое расширение imagick не установлено или отключено.
Внимание! Рекомендуемое расширение zip не установлено или отключено.

Была еще какая-то ошибка, но потом она исчезла, и самое главное сайт просел по скорости и отклику, так называемый TTFB стал больше. Короче пришлось все вернуть взад.

LEOnidUKG
На сайте с 25.11.2006
Offline
1546
#7
но к сожалению, она не принесла ускорение в 100ms

Чего-чего она должна была принести? Ой не так программирование работает, совсем не так :)

✅ Трастовых площадок под размещение статей и ссылок. Опыт 12 лет! ( https://searchengines.guru/ru/forum/675690 ) ⭐ Купить вечные трастовые ссылки для сайта ( https://getmanylinks.ru/?srh ) ⭐ Ускорение ваших сайтов (WP, Opencart и др.) + Настройка сервера ( https://searchengines.guru/ru/forum/997205 )
Dmitriy_2014
На сайте с 01.07.2014
Offline
124
#8
LEOnidUKG:
Чего-чего она должна была принести? Ой не так программирование работает, совсем не так :)

Я знаю, но я верю в чудеса :), тем более все всегда говорят, что новая версия PHP приносит +200% к производительности, все время какие-то синтетические тесты рисуют графики с улучшением производительности и т.д., и т.п. да я понимаю, что это все так, ладно потестил и ладно.

LEOnidUKG
На сайте с 25.11.2006
Offline
1546
#9

Вы в соседней теме говорили, что у вас ISP панель.

Там из коробки есть PHP 7.4 зачем самому собирать то?

Dmitriy_2014
На сайте с 01.07.2014
Offline
124
#10
LEOnidUKG:
Вы в соседней теме говорили, что у вас ISP панель.

Там из коробки есть PHP 7.4 зачем самому собирать то?

WordPress в рекомендациях советует использовать 7.3 версию.

PHP — язык программирования, используемый для создания WordPress. Новые версии PHP работают быстрее и более безопасны. Используя актуальные версии PHP, вы улучшаете производительность и безопасность сайта. Минимальная рекомендуемая версия PHP — 7.3.

К сожалению, у меня старенькая версия ISPmanager’а, но там можно выбирать версии PHP, но не по умолчанию (может там были по умолчанию, но старые), а новые установленные.

Попробую как ни будь 7.4, если она установиться. Ну и как выяснилось ZIP таки нужен WordPress’у, и ещё какой-то imagick.

12

Авторизуйтесь или зарегистрируйтесь, чтобы оставить комментарий