WordPress. Обновление PHP до последней версии и проблемы с плагинами (RusToLat)

12 3
SZ
На сайте с 09.07.2011
Offline
123
1989

Для WordPress нужно обновлять PHP до последней версии. Новость - /ru/news/2016375

В настройках хостинга для одного сайта выставил PHP 7.2.10 (есть еще 7.3.0RC2, но ее не пробовал включать). Сам WordPress отлично работает на последней версии PHP. Но вот плагины...

Сразу появилась ошибка, связанная с популярным плагином RusToLat. Старый он уже. Везде на сайте выводится такая строчка:

Warning: count(): Parameter must be an array or an object that implements Countable in .../wp-content/plugins/rustolat/rus-to-lat.php on line 1103

Вопрос: каким плагином можно заменить RusToLat, чтобы он не заменил УРЛы старых записей? Есть еще Cyr-To-Lat и Cyr to Lat enhanced. Но они вроде как меняют старые УРЛы сразу после установки. Может кто-то уже менял? Подскажите, пожалуйста.

Еще по теме: плагином PHP Compatibility Checker можно просканировать тему и все плагины на совместимость с PHP 7.2.

Для RusToLat – Warnings: 1. По идеи, все должно работать. А для WP No External Links - Errors: 15. Его, походу, так же нужно чем-то заменить. Хоть и обновлялся он не так давно. Возможно, разработчики WP No External Links выпустят обновление.

Весело живем:) Чувствую, придется попотеть с этими старыми плагинами.

-Seller-
На сайте с 31.08.2008
Offline
135
#1

А если PHP не обновлять, то старые плагины (RusToLat) будут работать как и прежде, но просто уровень безопасности снизится или еще что-то будет?

LEOnidUKG
На сайте с 25.11.2006
Offline
1586
#2

Скачал плагин: https://ru.wordpress.org/plugins/rustolat/

Там нет 1103 строк.

✅ Трастовых площадок под размещение статей и ссылок. Опыт 12 лет! ( https://searchengines.guru/ru/forum/675690 ) ⭐ Купить вечные трастовые ссылки для сайта ( https://getmanylinks.ru/?srh ) ⭐ Ускорение ваших сайтов (WP, Opencart и др.) + Настройка сервера ( https://searchengines.guru/ru/forum/997205 )
SZ
На сайте с 09.07.2011
Offline
123
#3
-Seller-:
А если PHP не обновлять, то старые плагины (RusToLat) будут работать как и прежде, но просто уровень безопасности снизится или еще что-то будет?

WordPress перестанет получать обновления безопасности.

LEOnidUKG:
Скачал плагин: https://ru.wordpress.org/plugins/rustolat/

Там нет 1103 строк.

Спасибо! Скачал плагин по ссылке, перезаписал, активировал и все работает! Ошибки нет.

Что же это получается, у меня какой-то неправильный RusToLat был установлен?

LEOnidUKG
На сайте с 25.11.2006
Offline
1586
#4
Что же это получается, у меня какой-то неправильный RusToLat был установлен?

нам то откуда знать, что у вас там было?

SZ
На сайте с 09.07.2011
Offline
123
#5

PHP Compatibility Checker выдал 15 ошибок для WP No External Links, но он вроде как работает. Никаких проблем пока не заметил.

LEOnidUKG
На сайте с 25.11.2006
Offline
1586
#6

Исправлять руками или искать другой плагин.

melkozaur
На сайте с 06.04.2010
Offline
496
#7

RusToLat устарел, все остальные тоже не очень новые, но работают.

Проблема в том, что у них разные системы замены символов.

Серверы в NL/US со скидкой 30% нашим читателям: E5-2650v4/10GB DDR4/240GB SSD/1 Gbps - от $20: https://ua-hosting.company/vps/nl SEO без компромиссов: https://seoleaks.net SEOLEAKS - продвижение сайтов: https://www.instagram.com/seoleaks
SeVlad
На сайте с 03.11.2008
Offline
1455
#8
-Seller-:
А если PHP не обновлять, то старые плагины (RusToLat) будут работать как и прежде, но просто уровень безопасности снизится

Да. См http://php.net/supported-versions.php

Но это не мешает некоторым и сейчас держать сайты на <5,6 (даже на 5,2) и ловить вири в 1103 строках при всего 103 :)

SeraZwer:
WordPress перестанет получать обновления безопасности.

Не мели чушь.

SeraZwer:
Что же это получается, у меня какой-то неправильный RusToLat был установлен?

Получается что вирь у тебя преспокойно жил.

melkozaur:
RusToLat устарел, все остальные тоже не очень новые, но работают.
Проблема в том, что у них разные системы замены символов.

Ещё они по разному работают.

Напр RusToLat не трогает старые слаги (в см не транслитерирует), у cyr2lat есть проблемы с нек сочетаниями символов, а cyr3lat меняет слаги и вложений.

Но это всё фигня... Цирк начнётся через 10 дней.

Делаю хорошие сайты хорошим людям. Предпочтение коммерческим направлениям. Топики помощи с ⓌordPress (https://searchengines.guru/ru/forum/1032910 ) и основы безопасности сайтов ( https://searchengines.guru/ru/forum/774117 ). *** Помощь\консультации в топиках форума - БЕСПЛАТНО. Платные услуги ( https://wp.me/P3YHjQ-3 ) - с бюджетом от 150$ ***
LEOnidUKG
На сайте с 25.11.2006
Offline
1586
#9
WordPress перестанет получать обновления безопасности.

Там речь, что старые версии PHP перестанут обновляться.

Я вообще не понимаю, к чему там WP привязали, если речь идёт про все сайты, которые работают на старых версиях PHP. Но копирайтеры такие копирайтеры.

Оптимизайка
На сайте с 11.03.2012
Offline
396
#10
LEOnidUKG:
Там речь, что старые версии PHP перестанут обновляться.

Перестанут обновляться разработчиками PHP. Но бэкпорты обновлений безопасности мэйнтейнерами дистрибутивов никто не отменял ;)

⭐ BotGuard (https://botguard.net) ⭐ — защита вашего сайта от вредоносных ботов, воровства контента, клонирования, спама и хакерских атак!
12 3

Авторизуйтесь или зарегистрируйтесь, чтобы оставить комментарий