Не работает Open Graph

K
На сайте с 05.08.2014
Offline
31
2581

Не работает Open Graph в телеграме, скайпе и т.д

Вставил следующий код в <head>

<meta property="og:title" content="Интернет-магазин Техностор.ру - интернет-магазин бытовой техники, электроники, товаров для сада, дачи, стройки и ремонта" />
<meta property="og:description" content="Техностор.ру - интернет-магазин бытовой техники, электроники, товаров для сада, дачи, стройки и ремонта. Скидки и специальные предложения для покупателей." />
<meta property="og:type" content="website" />
<meta property="og:image" content="https://technostor.ru/dilshot/img/og-logo.jpg" />
<meta property="og:image:secure_url" content="https://technostor.ru/dilshot/img/og-logo.jpg" />
<meta property="og:url" content="https://technostor.ru/" />

тут вроде никаких критических ошибок, и всё отображается нормально

https://developers.facebook.com/tools/debug/sharing/

В чём может быть причина?

Целый день не могу разобраться, на других сайтах тот же код работает )

FladeX
На сайте с 07.11.2008
Offline
162
#1

Попробуйте добавить og:image:width и og:image:height. В значениях укажите актуальный размер картинки.

Услуги посредника на бирже контента: информационные статьи 40₽/1000, «продающие» тексты 50₽/1000. Пишите в личку. Помогаю правильно переехать на https (/ru/forum/973447). Подписывайтесь на мой канал в телеграм: https://t.me/fladex (https://t.me/fladex).
K
На сайте с 05.08.2014
Offline
31
#2
FladeX:
Попробуйте добавить og:image:width и og:image:height. В значениях укажите актуальный размер картинки.

я уже думал но, тогда придётся к каждому товару высчитывать размер?

FladeX
На сайте с 07.11.2008
Offline
162
#3

Начните хотя бы с главной страницы, просто чтобы проверить, в этом ли дело.

Далее по ситуации. Тем более если у вас движок формирует все остальные поля, то можно дописать функционал и по размеру изображений.

K
На сайте с 05.08.2014
Offline
31
#4

c og:image:width и og:image:height - то же не работает!

dma84
На сайте с 21.04.2009
Offline
164
#5

Бывало, что хостер блокировал запросы от некоторых сервисов, может в этом дело?

Z
На сайте с 20.07.2008
Offline
76
#6

Попробуйте убрать из хедера невалидные теги, переместив их перед закрывающим body

K
На сайте с 05.08.2014
Offline
31
#7
Zaandr:
Попробуйте убрать из хедера невалидные теги, переместив их перед закрывающим body

убрал, не помогает

думаю дело в Cloudflare...

[Удален]
#8
kirnoyseo:
думаю дело в Cloudflare...

Только хотел написать - а не клоудфларе ли там - опередили. Да, оно самое.

Вроде был способ решения проблемы, плюс там еще с метрикой некоторые траблы... Но мне то по существу пофиг - поищите кто активно с ним работает.

K
На сайте с 05.08.2014
Offline
31
#9

Так и не победил я Cloudflare, занатоки помогите!

Авторизуйтесь или зарегистрируйтесь, чтобы оставить комментарий