Битрикс - контент загружается до <html>

tommy-gung
На сайте с 22.11.2006
Offline
277
766

Перенесли сайт на другой хостинг. Теперь сначала загружается контент, а потом только сам вывод шаблона, начиная с html

в какую сторону смотреть, где искать проблемы?

сам сайт

Здесь не могла быть ваша реклама
L
На сайте с 10.02.2015
Offline
170
#1

Возможно перемудрили с буферизацией вывода.

На обоих хостингах Линуксы?

tommy-gung
На сайте с 22.11.2006
Offline
277
#2
livetv:
На обоих хостингах Линуксы?

на новом, да

	Linux host.ru 4.1.27-*** #1 SMP Mon Jul 25 10:56:32 MSK 2016 x86_64 

на старом, думаю, тоже

кеш отключал\чистил - не помогло

Appassionato
На сайте с 22.06.2010
Offline
270
#3

ob_start и т.д. криво обрабатываться или отключена.

Хостинг Работает, как Часы ( http://tinyurl.com/nze85xw ). Проверено за 11+ лет.
Gans Gauss
На сайте с 26.08.2015
Offline
138
#4

tommy-gung, скорее всего проблема с буферизацией. Надо смотреть где зациклилось. Нужно смотреть на предмет лишних ob_start/ob_end в системных файлах (в первую очередь в системных файлах типа /local/php_intrace/init.php и все что в нем подключаются). Ну и шаблон не помешало бы проверить еще разик

)
tommy-gung
На сайте с 22.11.2006
Offline
277
#5

разобрался. в dbconn.php стоял старый пусть к DOCUMENT_ROOT

if (!defined("BX_BUFFER_USED") AND $_SERVER['DOCUMENT_ROOT']=="/home/___/public_html" AND strpos($_SERVER['REQUEST_URI'], "/bitrix/")===false) define("BX_BUFFER_USED", false);

Авторизуйтесь или зарегистрируйтесь, чтобы оставить комментарий