Как установить модуль open_sll для php на CentOs?

Seredniy
На сайте с 17.03.2008
Offline
251
1139

Для отправки почты хочу использовать smtp через ssl. Выдает ошибку:

Unable to find the socket transport "SSL" - did you forget to enable it when you configured PHP?

Лезу в php.ini - там нет строк, нужных мне. Добавляю строчку extension=php_openssl.so - но все ровно пустота ведь в /usr/lib/php/modules у меня файлика php_openssl.so нету. Где его взять не знаю, как установить его - тоже не знаю.

Пробую установить через yum install php-openssl - пишет

Package matching php-common-5.3.3-46.el6_7.1.i686 already installed. Checking for update.  Nothing to do

Помогите)

---------- Добавлено 17.02.2016 в 00:23 ----------

Вот список пакетов пхпшных:

    php-bcmath-5.4.45-3.el6.remi.i686

php-pdo-5.4.45-3.el6.remi.i686
php-symfony-class-loader-2.7.9-2.el6.remi.noarch
php-mysql-5.4.45-3.el6.remi.i686
php-5.4.45-3.el6.remi.i686
php-pear-Net-Socket-1.0.14-1.el6.remi.noarch
php-pear-Net-Sieve-1.3.4-4.el6.remi.noarch
php-imap-5.4.45-3.el6.remi.i686
php-soap-5.4.45-3.el6.remi.i686
php-mbstring-5.4.45-3.el6.remi.i686
php-process-5.4.45-3.el6.remi.i686
php-php-gettext-1.0.11-12.el6.remi.noarch
php-symfony-common-2.7.9-2.el6.remi.noarch
php-cli-5.4.45-3.el6.remi.i686
php-gd-5.4.45-3.el6.remi.i686
php-intl-5.4.45-3.el6.remi.i686
php-pspell-5.4.45-3.el6.remi.i686
php-xml-5.4.45-3.el6.remi.i686
php-pear-Auth-SASL-1.0.6-1.el6.remi.noarch
php-pear-Net-LDAP2-2.2.0-1.el6.remi.noarch
php-pear-Net-SMTP-1.7.1-1.el6.remi.noarch
php-pear-Net-IDNA2-0.1.1-6.el6.remi.noarch
php-phpseclib-2.0.1-1.el6.remi.noarch
php-tidy-5.4.45-3.el6.remi.i686
php-tcpdf-dejavu-sans-fonts-6.2.12-1.el6.remi.noarch
php-recode-5.4.45-3.el6.remi.i686
vesta-php-0.9.8-15.i686
phpMyAdmin-4.4.15.2-1.el6.remi.noarch
php-mcrypt-5.4.45-3.el6.remi.i686
php-xmlrpc-5.4.45-3.el6.remi.i686
php-common-5.4.45-3.el6.remi.i686
php-ldap-5.4.45-3.el6.remi.i686
php-pear-1.10.1-1.el6.remi.noarch
php-kolab-net-ldap3-1.0.3-1.el6.remi.noarch
php-pear-Mail-Mime-1.10.0-1.el6.remi.noarch
php-tcpdf-6.2.12-1.el6.remi.noarch


---------- Добавлено 17.02.2016 в 01:17 ----------

Увы, ошибка была именно в скрипте. Странно, что выводилась именно такая ошибка
Wordpress и другие CMS: правки, настройка, верстка и натяжка шаблонов, разработка сайтов "под ключ" (/ru/forum/1008050)
tommy-gung
На сайте с 22.11.2006
Offline
269
#1

Что в phpinfo()?

как отправляешь почту?

Здесь не могла быть ваша реклама
PA
На сайте с 12.02.2016
Offline
24
#2

как-то не стыкуется

Package matching php-common-5.3.3-46.el6_7.1.i686 already installed.

и Ваш список установленных пакетов:

php-common-5.4.45-3.el6.remi.i686

проверьте, возможно у Вас установленно несколько версий пхп.

ну и смотреть phpinfo(), как посоветовали выше.

. . .
Seredniy
На сайте с 17.03.2008
Offline
251
#3

Спасибо всем, оказалось, что скрипт глючный был. ссл работает

Авторизуйтесь или зарегистрируйтесь, чтобы оставить комментарий