вплавить mod_rpaf в apache

Евгений Крупченко
На сайте с 27.09.2003
Offline
161
1371

во-первых, правильно ли понимаю, что вместо апачевского mod_remoteip (который есть в составе 2.4, но видел также вариант под 2.2) лучше все же использовать и на 2.2 и на 2.4 mod_rpaf ?

практического опыта пока нет ни с одним из них, но читал что с remoteip mod_rewrite все же не будет видеть реальный ip, а только ip proxy (nginx). так ли?

в общем, mod_rpaf.

повсюду нахожу лишь варианты его установки как dso, но есть желание абсолютно все (кроме php к сожалению) используемые модули использовать как static, т.е. скомпилированные внутри apache, а не подгружаемые потом.

реально ли? как именно?

просто добавить папку с его исходниками в modules и в configure добавить типа --enable-rpaf

потом make и make install... и нифига.

по httpd -l не вижу его

реально ли все же его "вплавить" внутрь apache?

N
На сайте с 06.05.2007
Offline
419
#1

Ну вы может ошибку компиляции покажете ?

Повторять ваш сомнительный эксперимент мало кому интересно.

Вы переоцениваете эффект от статической линковки.

Кнопка вызова админа ()
Евгений Крупченко
На сайте с 27.09.2003
Offline
161
#2

пробовал эти 3 модуля:

https://github.com/ttkzw/mod_remoteip-httpd22

https://gist.github.com/bfg/1042237

https://github.com/ttkzw/mod_rpaf-0.6

все через типа такого: configure --with-module=remoteip:mod_remoteip.so

на стадии make получаю ошибки типа таких:


Making all in remoteip
make[2]: вход в каталог «/install/httpd-2.2.31/modules/remoteip»
make[2]: *** Нет правила для сборки цели «all». Останов.
make[2]: выход из каталога «/install/httpd-2.2.31/modules/remoteip»
/install/httpd-2.2.31/build/rules.mk:72: ошибка выполнения рецепта для цели «all-recursive»
make[1]: *** [all-recursive] Ошибка 1
make[1]: выход из каталога «/install/httpd-2.2.31/modules»
/install/httpd-2.2.31/build/rules.mk:72: ошибка выполнения рецепта для цели «all-recursive»
make: *** [all-recursive] Ошибка 1
Andreyka
На сайте с 19.02.2005
Offline
821
#3

во-первых, правильно ли понимаю, что вместо апачевского mod_remoteip (который есть в составе 2.4, но видел также вариант под 2.2) лучше все же использовать и на 2.2 и на 2.4 mod_rpaf ?

Нет. Пост закрыт.

Не стоит плодить сущности без необходимости
Евгений Крупченко
На сайте с 27.09.2003
Offline
161
#4

насчет нет уже соглашусь. попробовал remoteip, вроде все работает как надо.

и он замечательно вставляется как static в 2.4

лишь в logformat надо поменять %h на %a, иначе в логах все также будут 127.0.0.1 вместо правильных ip

в 2.2 вообще теряется всякий смысл как посмотрю.

новый синтаксис allow,deny компенсируется модулем mod_access_compat, который заставляет 2.4 апач понимать старые htaccess'ы

с ssi необльшая заморочка тоже лечится одной строкой в конфиге.

2.2 был нужен лишь для совместимости, но как вижу можно уже на него полностью забить.

---

но пост не закрыт.

остается небольшой спортивный интерес. должен же быть способ.

если что-то работает как подгружаемый so модуль, то оно обязано также работать и как static модуль.

Авторизуйтесь или зарегистрируйтесь, чтобы оставить комментарий