Смена php на Debian 8 jessie

12
I
На сайте с 22.04.2015
Offline
33
8352

Есть сервер VPS с установленной Debian 8 jessie minimal. Задача установить php 5.4 (php-fpm)

Подключаю такие репозитории

( deb http://http.debian.net/debian wheezy main contrib non-free

deb http://http.debian.net/debian/ wheezy-updates main contrib non-free

deb http://security.debian.org/ wheezy/updates main contrib non-free )

Выдает ошибку при установке, проверю наличие apt-cache showpkg php5 - нужная версия есть .

Что делаю не правильно? Установку делаю на "чистую" систему (минимал). Панелей никаких нет- работаю через консоль.

Обмен электронных валют Я.Д, ВТС, РМ, AdvCash, OkPay, Приват24, Visa, Mastercard (http://internetmoney.exchange)
Оптимизайка
На сайте с 11.03.2012
Offline
396
#1

Если у вас jessie, почему вы добавляете репы для wheezy?

⭐ BotGuard (https://botguard.net) ⭐ — защита вашего сайта от вредоносных ботов, воровства контента, клонирования, спама и хакерских атак!
I
На сайте с 22.04.2015
Offline
33
#2

потому что нужно установить php 5.4. из jessie ставит 5.6, у меня сайт оптимизирован по 5.4. Из всего что нагуглил указаны эти репы. Потому и спрашую что не верно, возможно есть другие рабочие

Candidate
На сайте с 09.05.2012
Offline
36
#3

apt-get install php5=5.4.xx
I
На сайте с 22.04.2015
Offline
33
#4
Candidate:
apt-get install php5=5.4.xx

выполняю apt-cache showpkg php5

ответ

Providies:

5.4.45-0+deb7u1

5.4.44-0+deb7u1

выполняю apt-get install php5=5.4.45

ответ

Version 'php5.4.45' for 'php5' was not found

Аналогично в других вариантах и при подключении репов jessie

выполняю apt-get install php5-fpm

ответ

png 145888.png
Candidate
На сайте с 09.05.2012
Offline
36
#5

apt-get install php5=5.4.45-0+deb7u1

🙄

K5
На сайте с 21.07.2010
Offline
209
#6
deb http://security.debian.org/ wheezy/updates main contrib non-free

не рабочий, уберите его и пробуйте

apt-get update
apt-cache showpkg php5
аська 45два48499два записки на работе (http://memoryhigh.ru) помогу с сайтом, удалю вирусы, настрою впс -> отзывы ТУТ (/ru/forum/836248) и ТАМ (http://www.maultalk.com/topic140187.html) !!!всегда проверяйте данные людей, которые сами пишут вам в аську или скайп!!!
I
На сайте с 22.04.2015
Offline
33
#7

этак тоже пробовал. и с пробелами, и с запятыми- по всякому. похоже проблема не в этом.

kgtu5:
не рабочий, уберите его и пробуйте

убрал, ничего не поменялось

madoff
На сайте с 01.12.2009
Offline
235
#8
internetmoney:
Есть сервер VPS с установленной Debian 8 jessie minimal. Задача установить php 5.4 (php-fpm)
Подключаю такие репозитории
( deb http://http.debian.net/debian wheezy main contrib non-free

deb http://http.debian.net/debian/ wheezy-updates main contrib non-free

deb http://security.debian.org/ wheezy/updates main contrib non-free )

Выдает ошибку при установке, проверю наличие apt-cache showpkg php5 - нужная версия есть .
Что делаю не правильно? Установку делаю на "чистую" систему (минимал). Панелей никаких нет- работаю через консоль.

Закоментируйте все кроме wheezy и попробуйте поставить php5-fpm

Администратор Linux,Freebsd. (/ru/forum/494299) построения крупных проектов. ICQ#: 241606.
Candidate
На сайте с 09.05.2012
Offline
36
#9

Удалось решить задачу? Интересно же!

I
На сайте с 22.04.2015
Offline
33
#10
Candidate:
Удалось решить задачу? Интересно же!

к серверу не подходил эти дни. планирую сегодня сесть ковырять дальше, попробую то, что посоветовал madoff и др. варианты.

пока что если есть что посоветовать еще - пишите, буду пробовать, результаты отпишу здесь

12

Авторизуйтесь или зарегистрируйтесь, чтобы оставить комментарий