VPS от sweb.ru и upgrade

WSGU
На сайте с 07.10.2007
Offline
137
1153

Взял на пробу у них впску и вот сразу столкнулся с двумя проблемами:

1. сделал apt-get update и apt-get upgrade. Но обновления не устанавливаются

- linux-image-2.6.27-7-server, и теперь при каждом вызове apt-get, идет

попытка обновить этот пакет и все заканчивается ошибкой, что отнимает время и капает на нервы:

 Reading package lists... Done

Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up linux-image-2.6.27-7-server (2.6.27-7.16) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.27-7-server
grep: /proc/modules: No such file or directory
grep: /proc/modules: No such file or directory
grep: /proc/modules: No such file or directory
grep: /proc/modules: No such file or directory
grep: /proc/modules: No such file or directory
grep: /proc/modules: No such file or directory
grep: /proc/modules: No such file or directory
Not updating initrd symbolic links since we are being updated/reinstalled
(2.6.27-7.14 was configured last, according to dpkg)
Not updating image symbolic links since we are being updated/reinstalled
(2.6.27-7.14 was configured last, according to dpkg)
Running postinst hook script /sbin/update-grub.
Searching for GRUB installation directory ...
No GRUB directory found. To create a template run 'mkdir /boot/grub' first. To
install grub, install it manually or try the 'grub-install' command. ###
Warning, grub-install is used to change your MBR. ###

User postinst hook script [/sbin/update-grub] exited with value 1
dpkg: error processing linux-image-2.6.27-7-server (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
linux-image-2.6.27-7-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

Я так понимаю, что эта ошибка из-за запрета обновления ядра. Как запретить

попытки обновлять ядро не понятно.

2. Создал нового пользователя и почему-то терминал не принимает команды

клавиш: нажимаю клавишу вверх, должна показаться предыдущая команда, а

печатается ^[[A. Так же не работают другие управляющие клавиши. Пробовал

делать reset терминала - все так же. Под root все работает. Добавлял пользователя через useradd -U -m name.

Написал в техподдержку, прошло 9 часов, пока тишина.

M
На сайте с 16.09.2009
Offline
278
#1
WSGU:

- linux-image-2.6.27-7-server, и теперь при каждом вызове apt-get, идет
попытка обновить этот пакет и все заканчивается ошибкой, что отнимает время и капает на нервы:
User postinst hook script [/sbin/update-grub] exited with value 1
dpkg: error processing linux-image-2.6.27-7-server (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
linux-image-2.6.27-7-server
E: Sub-process /usr/bin/dpkg returned an error code (1)


Я так понимаю, что эта ошибка из-за запрета обновления ядра. Как запретить
попытки обновлять ядро не понятно.
2. Создал нового пользователя и почему-то терминал не принимает команды
клавиш: нажимаю клавишу вверх, должна показаться предыдущая команда, а
печатается ^[[A. Так же не работают другие управляющие клавиши. Пробовал
делать reset терминала - все так же. Под root все работает. Добавлял пользователя через useradd -U -m name.
Написал в техподдержку, прошло 9 часов, пока тишина.

1. в openvz/virtuozzo шаблонах устанавливаются псевдопакеты,

обеспечивающие зависимости ядра. Штатное обновление не должно

их трогать - это проблема тех, кто шаблон вашего дистрибутива настраивал

т.е. хостера.

Вы же не пытались сменить мажор-версию дистрибутива (например etch->lenny для debian)?

"Руками" что-то типа apt-get install linux-image-2.6.27-7-server не делали?

2. есть вероятность, что 1) к этому причастно. это исключено, до обновления

пробовали добавить пользователя?

Абонементное сопровождение серверов (Debian) Отправить личное сообщение (), написать письмо ().
WSGU
На сайте с 07.10.2007
Offline
137
#2

У них технология Xen. Прям только что получил ответ (ровно через 12 часов)

"

Нужно выполнить apt-get purge linux-image

Эта проблема была в старых образах VDS, сейчас она уже решена.

"

Выполнил рекомендованную команду, все то же - жду 5-10 минут попытку обновления ядра при использовании apt-get

Т.е. каким то образом вчера я заказал старый глючный образ VDS. На второй вопрос ответа не получил (пользователя добавлял до обновления). Что-то как то не пошло. Заказал возврат средств.

WSGU добавил 22.10.2009 в 15:08

myhand:

Вы же не пытались сменить мажор-версию дистрибутива (например etch->lenny для debian)?
"Руками" что-то типа apt-get install linux-image-2.6.27-7-server не делали?

только apt-get update и apt-get upgrade

M
На сайте с 16.09.2009
Offline
278
#3
WSGU:
(пользователя добавлял до обновления)

_проверяли_ (пункт 2) тоже _до_

WSGU
На сайте с 07.10.2007
Offline
137
#4
myhand:
_проверяли_ (пункт 2) тоже _до_

а вот это уже точно сказать не могу. Зато могу сделать выводы о тех. поддержке.

Авторизуйтесь или зарегистрируйтесь, чтобы оставить комментарий