Посоветуйте хостинг с PHP 4.4.0

N
На сайте с 21.09.2005
Offline
220
1068

Вообщем нужен такой хостинг.

Сейчас 6-ть сайтов на агаве. У них есть сервера с PHP 4.4.0, но обработка идет как CGI с эмуляцией mod_php. Мне нужно чтобы была обработка как простой Apache, иначе CMS не работает.

Хотелось бы услышать Ваши отзывы о нормальном хостинге с PHP 4.4.0

Поисковое продвижение сайтов в разных тематиках. 641-222
Z
На сайте с 12.01.2005
Offline
121
#1

Ну вообщем их можно понять, ибо как ты там настройки с mod_php не крути, но для хостера это потенциальная дыра в безопасности, так как в режиме модуля PHP для всех сайтов работает с правами одного пользователя.

Мой тебе совет смотри в сторону VDS, там во первых ты сможешь на одном аккаунте разместить все свои сайты, во вторых включить PHP в том режиме, который тебе необходим, без всякого риска.

Например (в порядке роста цен):

http://firstvds.ru

http://ruweb.net

http://ispserver.com

(у этих трех в качестве панели стоит ISPmanager и то в каком режиме включить PHP для сайта, настраивается прямо из панели).

у этих не знаю чо с панелью (помоему вообще нет)

http://rusonix.ru

http://masterhost.ru

а вообще можешь сделать выборку по хостингам предоставляющим "виртуальный выделенный сервер" на http://hostobzor.ru

Алексей Чекушкин http://firstvds.ru (http://firstvds.ru) - http://firstdedic.ru (http://firstdedic.ru) - http://firstssl.ru (http://firstssl.ru)
N
На сайте с 21.09.2005
Offline
220
#2
Zaicev:
Ну вообщем их можно понять, ибо как ты там настройки с mod_php не крути, но для хостера это потенциальная дыра в безопасности, так как в режиме модуля PHP для всех сайтов работает с правами одного пользователя.

Не, насколько я понял ситуация в следующем:

На одном серваке располагается 2-е версии PHP:

1)4.3.9

2)4.4.0

Через htaccess можно использовать и ту и другую. В связи с этим и сделали немного другую интерпретацию PHP. НО на том серваке где у меня сейчас все лежит - все работает в нормальном режиме. Я не спец в этих вопросах, мне не совсем понятно что к чему, но то что я говорю - это логично или они Агава просто решила поднять свою безопасность?

Z
На сайте с 12.01.2005
Offline
121
#3

Как вариант, может быть это сделано, чтобы иметь 2 (и более) версий PHP на одном сервере. В одном апаче не может больше чем один PHP (одной версии) работать как модуль. Поэтому другие версии (если их хотят клиенты) ставятся как CGI.

I
На сайте с 13.07.2005
Offline
3
#4

Nitro, у нас PHP подключается к Apache в виде модуля. Я правильно понимаю, Вас это интересует?

Капитальный Хостинг (http://capitalhost.ru/)
N
На сайте с 21.09.2005
Offline
220
#5
Intermedia:
Nitro, у нас PHP подключается к Apache в виде модуля. Я правильно понимаю, Вас это интересует?

Именно. И версии 4.4.0 и выше

I
На сайте с 13.07.2005
Offline
3
#6
Nitro:
Именно. И версии 4.4.0 и выше

А PHP 4.3.10 не подойдет?

N
На сайте с 21.09.2005
Offline
220
#7
Intermedia:
А PHP 4.3.10 не подойдет?

Нет, к сожалению. Именно 4.4.0 и Выше

Авторизуйтесь или зарегистрируйтесь, чтобы оставить комментарий