Нужен мастер по DLE

RasJkeee
На сайте с 24.01.2011
Offline
53
554

Пациент - arigato.tv

Что нужно сделать:

1. Обновить скрипт чтобы поддерживал iframe

2. Настроить вид спойлера как на animespirit.ru

Насчёт оплаты договоримся думаю.

K
На сайте с 05.05.2013
Offline
34
#1

function ShowOrHide(b){var c=$("#"+b);b=document.getElementById("image-"+b)?document.getElementById("image-"+b):null;var d=1E3*(c.height()/200);3E3<d&&(d=3E3);250>d&&(d=250);"none"==c.css("display")?(c.show("blind",{},d),b&&(b.src=dle_root+"templates/"+dle_skin+"/dleimages/spoiler-minus.gif")):(2E3<d&&(d=2E3),c.hide("blind",{},d),b&&(b.src=dle_root+"templates/"+dle_skin+"/dleimages/spoiler-plus.gif"))}

и к ссылкам приклеить что-то такое

<a href="javascript:ShowOrHide('#')">Открыть:</a>
eis
На сайте с 18.10.2008
Offline
466
eis
#2

RasJkeee, так ведь DLE поддерживает iframe!☝

- Здесь я покупаю вечные ссылки на свои сайты! (https://backlinkator.com) - сотни ссылок за копейки
RasJkeee
На сайте с 24.01.2011
Offline
53
#3

нет у меня DLE 9.4

S
На сайте с 28.06.2011
Offline
19
#4

iframe в dle убивает "parce.class.php" можеш отключить эту защиту убрав строки:

$source = preg_replace( "#<iframe#i", "&lt;iframe", $source );

$source = preg_replace( "#</iframe>#i", "</iframe>", $source );

В файле: engine/classes/parce.class.php

Но делать это, не советую )

Лучше возьми и скачай dle 9.6 и возьми файл "parce.class.php" из дистрибутива и замени свой старый c dle 9.4

В итоге iframe будут отображаться в новости только еcли там url доверенного сайта.

Авторизуйтесь или зарегистрируйтесь, чтобы оставить комментарий