Насколько опасно пользоваться неподдерживаемой серверной операционной системой?

Dmitriy_2014
На сайте с 01.07.2014
Offline
124
417

Всем привет!

Например, есть серверная Unix-like операционная система CentOS её поддержка по критическим обновлениям заканчивается 30 ноября 2020 года, чем может грозить дальнейшее использование неподдерживаемой ОС.

Заранее всем спасибо за ответы!

lonelywoolf
На сайте с 23.12.2013
Offline
151
#1

Из-за отсутствия обновлений сервер будет взломан.

Платный и бесплатный хостинг с защитой от DDoS (http://aquinas.su)
Dmitriy_2014
На сайте с 01.07.2014
Offline
124
#2
lonelywoolf:
Из-за отсутствия обновлений сервер будет взломан.

Это как-то опасно звучит :), а сразу или допустим есть год, два по времени?

-S
На сайте с 10.12.2006
Offline
Модератор1185
#3
Dmitriy_2014:
Это как-то опасно звучит :), а сразу или допустим есть год, два по времени?

Важнее задать вопрос - зачем ее использовать, если хватает альтернатив.

Дейл Купер
На сайте с 26.12.2016
Offline
110
#4
Dmitriy_2014:
а сразу или допустим есть год, два по времени?

Как повезет. Если ломают и не просроченные, то у Вас шансы возрастут в разы.

Просто личный блог. Excel, VBA, аналитика https://xvba.ru/
Dmitriy_2014
На сайте с 01.07.2014
Offline
124
#5
-= Serafim =-:
Важнее задать вопрос - зачем ее использовать, если хватает альтернатив.

Это понятно, но одно дело дома Windows переустановить, а другое на сервере все менять к примеру.

---------- Добавлено 29.03.2020 в 20:59 ----------

Дейл Купер:
Как повезет. Если ломают и не просроченные, то у Вас шансы возрастут в разы.

Антивирусные системы и файрволы перестают быть защитниками системы в таком случае я так понял.

lonelywoolf
На сайте с 23.12.2013
Offline
151
#6

Dmitriy_2014, Телепаты в отпуске. Конкретного ответа вы не получите. Планируйте миграцию на что-то более современное.

edogs software
На сайте с 15.12.2005
Offline
714
#7
lonelywoolf:
Из-за отсутствия обновлений сервер будет взломан.

На одном из серверов заказчика - центос 5, денег на апгрейд админам он жмет. Для нее уязвимостей известных нет, как и для пакетов которые там используются. В 19 году был целый вал уязвимостей, то к постфиксу, то еще к чему-то - всё мимо кассы, т.к. они работают только на более свежих версиях, а там старье. Не все так однозначно.

p.s.: По уму конечно надо апдейтить и следить за апдейтами безопасности, это бес порно.

Разработка крупных и средних проектов. Можно с криптой. Разумные цены. Хорошее качество. Адекватный подход.
lonelywoolf
На сайте с 23.12.2013
Offline
151
#8

edogs, На самом деле, скорее всего, уязвимости есть, просто о них никто не знает и не ищет. Такое себе Security by obscurity.

У меня у клиента есть сервер с PHP 4.4.9 - тоже по такой же причине.

Andreyka
На сайте с 19.02.2005
Offline
817
#9

Если вы поместите этот образ в контейнер и запустите его через NAT то существенно снизите риск взлома. Хотя и не полностью.

Не стоит плодить сущности без необходимости

Авторизуйтесь или зарегистрируйтесь, чтобы оставить комментарий