npm run dev проблема при этой команде

J
На сайте с 28.05.2019
Offline
14
581

npm run dev

> @ dev /var/www/html

> npm run development

> @ development /var/www/html

> cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --hide-modules --config=node_modules/laravel-mix/setup/webpack.config.js

sh: 1: cross-env: not found

npm ERR! Linux 5.0.0-29-generic

npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "run" "development"

npm ERR! node v8.10.0

npm ERR! npm v3.5.2

npm ERR! file sh

npm ERR! code ELIFECYCLE

npm ERR! errno ENOENT

npm ERR! syscall spawn

npm ERR! @ development: `cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --hide-modules --config=node_modules/laravel-mix/setup/webpack.config.js`

npm ERR! spawn ENOENT

npm ERR!

npm ERR! Failed at the @ development script 'cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --hide-modules --config=node_modules/laravel-mix/setup/webpack.config.js'.

npm ERR! Make sure you have the latest version of node.js and npm installed.

npm ERR! If you do, this is most likely a problem with the package,

npm ERR! not with npm itself.

npm ERR! Tell the author that this fails on your system:

npm ERR! cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --hide-modules --config=node_modules/laravel-mix/setup/webpack.config.js

npm ERR! You can get information on how to open an issue for this project with:

npm ERR! npm bugs

npm ERR! Or if that isn't available, you can get their info via:

npm ERR! npm owner ls

npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:

npm ERR! /var/www/html/npm-debug.log

npm ERR! Linux 5.0.0-29-generic

npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "run" "dev"

npm ERR! node v8.10.0

npm ERR! npm v3.5.2

npm ERR! code ELIFECYCLE

npm ERR! @ dev: `npm run development`

npm ERR! Exit status 1

npm ERR!

npm ERR! Failed at the @ dev script 'npm run development'.

npm ERR! Make sure you have the latest version of node.js and npm installed.

npm ERR! If you do, this is most likely a problem with the package,

npm ERR! not with npm itself.

npm ERR! Tell the author that this fails on your system:

npm ERR! npm run development

npm ERR! You can get information on how to open an issue for this project with:

npm ERR! npm bugs

npm ERR! Or if that isn't available, you can get their info via:

npm ERR! npm owner ls

npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:

npm ERR! /var/www/html/npm-debug.log

tommy-gung
На сайте с 22.11.2006
Offline
261
#1

npm install сделал?

> sh: 1: cross-env: not found

Здесь не могла быть ваша реклама
S
На сайте с 30.09.2016
Offline
459
#2

jpchv, завязывай здесь флудить. Это не тот раздел. Брысь в "Администрирование серверов".

Отпилю лишнее, прикручу нужное, выправлю кривое. Вытравлю вредителей.
J
На сайте с 28.05.2019
Offline
14
#3

npm install сделал?

да

---------- Добавлено 29.09.2019 в 04:45 ----------

npm install --global cross-env

npm WARN checkPermissions Missing write access to /usr/local/lib

/usr/local/lib

└─┬ cross-env@6.0.0

└─┬ cross-spawn@7.0.0

├── path-key@3.1.0

├─┬ shebang-command@1.2.0

│ └── shebang-regex@1.0.0

└─┬ which@1.3.1

└── isexe@2.0.0

npm ERR! Linux 5.0.0-29-generic

npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install" "--global" "cross-env"

npm ERR! node v8.10.0

npm ERR! npm v3.5.2

npm ERR! path /usr/local/lib

npm ERR! code EACCES

npm ERR! errno -13

npm ERR! syscall access

npm ERR! Error: EACCES: permission denied, access '/usr/local/lib'

npm ERR! { Error: EACCES: permission denied, access '/usr/local/lib'

npm ERR! errno: -13,

npm ERR! code: 'EACCES',

npm ERR! syscall: 'access',

npm ERR! path: '/usr/local/lib' }

npm ERR!

npm ERR! Please try running this command again as root/Administrator.

npm ERR! Please include the following file with any support request:

npm ERR! /var/www/html/npm-debug.log

---------- Добавлено 29.09.2019 в 04:47 ----------

npm install cross-env

/home/php

└─┬ cross-env@6.0.0

└─┬ cross-spawn@7.0.0

├── path-key@3.1.0

├─┬ shebang-command@1.2.0

│ └── shebang-regex@1.0.0

└─┬ which@1.3.1

└── isexe@2.0.0

npm WARN enoent ENOENT: no such file or directory, open '/home/php/package.json'

npm WARN php No description

npm WARN php No repository field.

npm WARN php No README data

npm WARN php No license field.

---------- Добавлено 29.09.2019 в 04:48 ----------

npm install cross-env

/home/php

└─┬ cross-env@6.0.0

└─┬ cross-spawn@7.0.0

├── path-key@3.1.0

├─┬ shebang-command@1.2.0

│ └── shebang-regex@1.0.0

└─┬ which@1.3.1

└── isexe@2.0.0

npm WARN enoent ENOENT: no such file or directory, open '/home/php/package.json'

npm WARN php No description

npm WARN php No repository field.

npm WARN php No README data

npm WARN php No license field.

IL
На сайте с 20.04.2007
Offline
415
#4
jpchv:
npm ERR! Please try running this command again as root/Administrator.

Отчего б не попробовать сделать то, что система рекомендует?

J
На сайте с 28.05.2019
Offline
14
#5

npm install

npm WARN deprecated extract-text-webpack-plugin@3.0.2: Deprecated. Please use https://github.com/webpack-contrib/mini-css-extract-plugin

npm WARN deprecated browserslist@2.11.3: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.

npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.

npm WARN deprecated flatten@1.0.2: I wrote this module a very long time ago; you should use something else.

loadDep:ware → request ▀ ╢██████████████████████████████████████░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░╟

npm WARN deprecated gulp-util@3.0.8: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5

npm WARN prefer global node-gyp@3.8.0 should be installed with -g

> node-sass@4.12.0 install /var/www/html/node_modules/node-sass

> node scripts/install.js

Cached binary found at /home/php/.npm/node-sass/4.12.0/linux-x64-57_binding.node

> core-js@2.6.9 postinstall /var/www/html/node_modules/core-js

> node scripts/postinstall || echo "ignore"

> uglifyjs-webpack-plugin@0.4.6 postinstall /var/www/html/node_modules/webpack/node_modules/uglifyjs-webpack-plugin

> node lib/post_install.js

> node-sass@4.12.0 postinstall /var/www/html/node_modules/node-sass

> node scripts/build.js

Binary found at /var/www/html/node_modules/node-sass/vendor/linux-x64-57/binding.node

Testing binary

Binary is fine

> pngquant-bin@4.0.0 postinstall /var/www/html/node_modules/pngquant-bin

> node lib/install.js

⚠ The `/var/www/html/node_modules/pngquant-bin/vendor/pngquant` binary doesn't seem to work correctly

⚠ pngquant pre-build test failed

ℹ compiling from source

✔ pngquant pre-build test passed successfully

✖ Error: pngquant failed to build, make sure that libpng-dev is installed

at Promise.all.then.arr (/var/www/html/node_modules/pngquant-bin/node_modules/bin-build/node_modules/execa/index.js:231:11)

at <anonymous>

at process._tickCallback (internal/process/next_tick.js:188:7)

/var/www/html

├── autoprefixer@7.2.6 extraneous

├─┬ axios@0.16.2

│ ├─┬ follow-redirects@1.9.0

│ │ └─┬ debug@3.2.6

│ │ └── ms@2.1.2

│ └── is-buffer@1.1.6

├── babel-loader@7.1.5 extraneous

├── babel-plugin-transform-object-rest-spread@6.26.0 extraneous

├── babel-plugin-transform-runtime@6.23.0 extraneous

├── babel-preset-env@1.7.0 extraneous

├── bootstrap-sass@3.4.1

├── chokidar@1.7.0 extraneous

├── concatenate@0.0.2 extraneous

├─┬ cross-env@5.2.1

│ └─┬ cross-spawn@6.0.5

│ ├── semver@5.7.1

│ └─┬ which@1.3.1

│ └── isexe@2.0.0

├── css-loader@0.28.11 extraneous

├── dotenv@4.0.0 extraneous

├── dotenv-expand@4.2.0 extraneous

├── extract-text-webpack-plugin@3.0.2 extraneous

├── file-loader@0.11.2 extraneous

├── friendly-errors-webpack-plugin@1.7.0 extraneous

├── fs-extra@3.0.1 extraneous

├── html-loader@0.4.5 extraneous

├── imagemin@5.3.1 extraneous

├── imagemin-gifsicle@5.2.0 extraneous

├── imagemin-mozjpeg@7.0.0 extraneous

├── imagemin-optipng@5.2.1 extraneous

├── imagemin-svgo@6.0.0 extraneous

├── jquery@3.4.1

├── lodash@4.17.15

├── md5@2.2.1 extraneous

├── node-sass@4.12.0 extraneous

├── postcss-loader@2.1.6 extraneous

├── resolve-url-loader@2.3.2 extraneous

├── sass-loader@6.0.7 extraneous

├── style-loader@0.18.2 extraneous

├── uglifyjs-webpack-plugin@1.3.0 extraneous

├── vue@2.6.10

├── vue-loader@13.7.3 extraneous

├── vue-template-compiler@2.6.10 extraneous

├── webpack@3.12.0 extraneous

├── webpack-chunk-hash@0.4.0 extraneous

├── webpack-dev-server@2.11.5 extraneous

├── webpack-merge@4.2.2 extraneous

└── webpack-notifier@1.8.0 extraneous

npm WARN optional Skipping failed optional dependency /chokidar/fsevents:

npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.9

npm WARN optional Skipping failed optional dependency /watchpack/chokidar/fsevents:

npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.9

npm WARN optional Skipping failed optional dependency /webpack-dev-server/chokidar/fsevents:

npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.9

npm WARN ajv-keywords@3.4.1 requires a peer of ajv@^6.9.1 but none was installed.

npm ERR! Linux 5.0.0-29-generic

npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install"

npm ERR! node v8.10.0

npm ERR! npm v3.5.2

npm ERR! code ELIFECYCLE

npm ERR! pngquant-bin@4.0.0 postinstall: `node lib/install.js`

npm ERR! Exit status 1

npm ERR!

npm ERR! Failed at the pngquant-bin@4.0.0 postinstall script 'node lib/install.js'.

npm ERR! Make sure you have the latest version of node.js and npm installed.

npm ERR! If you do, this is most likely a problem with the pngquant-bin package,

npm ERR! not with npm itself.

npm ERR! Tell the author that this fails on your system:

npm ERR! node lib/install.js

npm ERR! You can get information on how to open an issue for this project with:

npm ERR! npm bugs pngquant-bin

npm ERR! Or if that isn't available, you can get their info via:

npm ERR! npm owner ls pngquant-bin

npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:

npm ERR! /var/www/html/npm-debug.log

---------- Добавлено 29.09.2019 в 07:05 ----------

npm install

npm WARN checkPermissions Missing write access to /var/www/html/node_modules

/var/www/html

├─┬ cross-env@5.2.1

│ └─┬ cross-spawn@6.0.5

│ ├── nice-try@1.0.5

│ ├── path-key@2.0.1

│ └─┬ shebang-command@1.2.0

│ └── shebang-regex@1.0.0

├─┬ imagemin@5.3.1

│ ├─┬ globby@6.1.0

│ │ └── pify@2.3.0

│ └── pify@2.3.0

├─┬ imagemin-gifsicle@5.2.0

│ ├─┬ exec-buffer@3.2.0

│ │ └─┬ execa@0.7.0

│ │ └── cross-spawn@5.1.0

│ └─┬ gifsicle@3.0.4

│ └─┬ bin-build@2.2.0

│ ├─┬ archive-type@3.2.0

│ │ └── file-type@3.9.0

│ ├─┬ decompress@3.0.0

│ │ ├─┬ buffer-to-vinyl@1.1.0

│ │ │ └── file-type@3.9.0

│ │ ├─┬ decompress-tarbz2@3.1.0

│ │ │ └─┬ seek-bzip@1.0.5

│ │ │ └─┬ commander@2.8.1

│ │ │ └── graceful-readlink@1.0.1

│ │ └─┬ decompress-unzip@3.4.0

│ │ └─┬ yauzl@2.10.0

│ │ ├── buffer-crc32@0.2.13

│ │ └─┬ fd-slicer@1.1.0

│ │ └── pend@1.2.0

│ └─┬ download@4.4.3

│ ├─┬ filenamify@1.2.1

│ │ ├── strip-outer@1.0.1

│ │ └── trim-repeated@1.0.0

│ └─┬ got@5.7.1

│ ├── is-retry-allowed@1.2.0

│ ├── lowercase-keys@1.0.1

│ └── url-parse-lax@1.0.0

├─┬ imagemin-mozjpeg@7.0.0

│ └─┬ execa@0.8.0

│ ├── cross-spawn@5.1.0

│ ├── get-stream@3.0.0

│ ├── npm-run-path@2.0.2

│ └── strip-eof@1.0.0

├─┬ laravel-mix@1.7.2

│ ├─┬ img-loader@2.0.1

│ │ └─┬ imagemin-pngquant@5.1.0

│ │ ├── execa@0.10.0

│ │ └─┬ pngquant-bin@4.0.0

│ │ ├─┬ bin-build@3.0.0

│ │ │ ├─┬ decompress@4.2.0

│ │ │ │ ├── decompress-tar@4.1.1

│ │ │ │ ├─┬ decompress-tarbz2@4.1.1

│ │ │ │ │ ├── file-type@6.2.0

│ │ │ │ │ └─┬ unbzip2-stream@1.3.3

│ │ │ │ │ └── buffer@5.4.3

│ │ │ │ ├── decompress-targz@4.1.1

│ │ │ │ ├─┬ decompress-unzip@4.0.1

│ │ │ │ │ ├── file-type@3.9.0

│ │ │ │ │ └── get-stream@2.3.1

│ │ │ │ ├── pify@2.3.0

│ │ │ │ └─┬ strip-dirs@2.1.0

│ │ │ │ └── is-natural-number@4.0.1

│ │ │ ├─┬ download@6.2.5

│ │ │ │ ├─┬ caw@2.0.1

│ │ │ │ │ ├─┬ get-proxy@2.1.0

│ │ │ │ │ │ └─┬ npm-conf@1.1.3

│ │ │ │ │ │ └─┬ config-chain@1.1.12

│ │ │ │ │ │ └── proto-list@1.2.4

│ │ │ │ │ ├─┬ isurl@1.0.0

│ │ │ │ │ │ ├─┬ has-to-string-tag-x@1.4.1

│ │ │ │ │ │ │ └── has-symbol-support-x@1.4.2

│ │ │ │ │ │ └── is-object@1.0.1

│ │ │ │ │ ├── tunnel-agent@0.6.0

│ │ │ │ │ └── url-to-options@1.0.1

│ │ │ │ ├─┬ ext-name@5.0.0

│ │ │ │ │ ├── ext-list@2.2.2

│ │ │ │ │ └── sort-keys-length@1.0.1

│ │ │ │ ├── file-type@5.2.0

│ │ │ │ ├─┬ filenamify@2.1.0

│ │ │ │ │ └── filename-reserved-regex@2.0.0

│ │ │ │ ├── get-stream@3.0.0

│ │ │ │ ├─┬ got@7.1.0

│ │ │ │ │ ├─┬ decompress-response@3.3.0

│ │ │ │ │ │ └── mimic-response@1.0.1

│ │ │ │ │ ├── duplexer3@0.1.4

│ │ │ │ │ ├── get-stream@3.0.0

│ │ │ │ │ ├── p-cancelable@0.3.0

│ │ │ │ │ └── timed-out@4.0.1

│ │ │ │ ├─┬ p-event@1.3.0

│ │ │ │ │ └── p-timeout@1.2.1

│ │ │ │ └── pify@3.0.0

│ │ │ ├─┬ execa@0.7.0

│ │ │ │ ├── cross-spawn@5.1.0

│ │ │ │ └── get-stream@3.0.0

│ │ │ └─┬ p-map-series@1.0.0

│ │ │ └── p-reduce@1.0.0

│ │ └─┬ execa@0.10.0

│ │ ├── cross-spawn@6.0.5

│ │ └── get-stream@3.0.0

│ └─┬ yargs@8.0.2

│ └─┬ read-pkg-up@2.0.0

│ └─┬ read-pkg@2.0.0

│ └─┬ load-json-file@2.0.0

│ └── pify@2.3.0

├─┬ node-sass@4.12.0

│ ├─┬ meow@3.7.0

│ │ └─┬ read-pkg-up@1.0.1

│ │ └─┬ read-pkg@1.1.0

│ │ ├─┬ load-json-file@1.1.0

│ │ │ └── pify@2.3.0

│ │ └─┬ path-type@1.1.0

│ │ └── pify@2.3.0

│ └─┬ request@2.88.0

│ └── tunnel-agent@0.6.0

└─┬ sass-loader@6.0.7

└── pify@3.0.0

npm WARN optional Skipping failed optional dependency /chokidar/fsevents:

npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.9

npm WARN optional Skipping failed optional dependency /watchpack/chokidar/fsevents:

npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.9

npm WARN optional Skipping failed optional dependency /webpack-dev-server/chokidar/fsevents:

npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.9

npm WARN ajv-keywords@3.4.1 requires a peer of ajv@^6.9.1 but none was installed.

npm ERR! Linux 5.0.0-29-generic

npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install"

npm ERR! node v8.10.0

npm ERR! npm v3.5.2

npm ERR! path /var/www/html/node_modules

npm ERR! code EACCES

npm ERR! errno -13

npm ERR! syscall access

npm ERR! Error: EACCES: permission denied, access '/var/www/html/node_modules'

npm ERR! { Error: EACCES: permission denied, access '/var/www/html/node_modules'

npm ERR! errno: -13,

npm ERR! code: 'EACCES',

npm ERR! syscall: 'access',

npm ERR! path: '/var/www/html/node_modules' }

npm ERR!

npm ERR! Please try running this command again as root/Administrator.

npm ERR! Please include the following file with any support request:

npm ERR! /var/www/html/npm-debug.log

IL
На сайте с 20.04.2007
Offline
415
#6
jpchv:

npm WARN checkPermissions Missing write access to /var/www/html/node_modules
...
npm ERR! Please try running this command again as root/Administrator.

Эм...

10 раз эм..

J
На сайте с 28.05.2019
Offline
14
#7

npm install

npm WARN deprecated extract-text-webpack-plugin@3.0.2: Deprecated. Please use https://github.com/webpack-contrib/mini-css-extract-plugin

npm WARN deprecated browserslist@2.11.3: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.

npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.

npm WARN deprecated flatten@1.0.2: I wrote this module a very long time ago; you should use something else.

loadDep:ware → get ▄ ╢██████████████████████████████████████░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░╟

npm WARN deprecated gulp-util@3.0.8: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5

npm WARN prefer global node-gyp@3.8.0 should be installed with -g

> node-sass@4.12.0 install /var/www/html/node_modules/node-sass

> node scripts/install.js

Cached binary found at /home/php/.npm/node-sass/4.12.0/linux-x64-57_binding.node

> core-js@2.6.9 postinstall /var/www/html/node_modules/core-js

> node scripts/postinstall || echo "ignore"

> uglifyjs-webpack-plugin@0.4.6 postinstall /var/www/html/node_modules/webpack/node_modules/uglifyjs-webpack-plugin

> node lib/post_install.js

> node-sass@4.12.0 postinstall /var/www/html/node_modules/node-sass

> node scripts/build.js

Binary found at /var/www/html/node_modules/node-sass/vendor/linux-x64-57/binding.node

Testing binary

Binary is fine

> pngquant-bin@4.0.0 postinstall /var/www/html/node_modules/pngquant-bin

> node lib/install.js

⚠ The `/var/www/html/node_modules/pngquant-bin/vendor/pngquant` binary doesn't seem to work correctly

⚠ pngquant pre-build test failed

ℹ compiling from source

✔ pngquant pre-build test passed successfully

✖ Error: pngquant failed to build, make sure that libpng-dev is installed

at Promise.all.then.arr (/var/www/html/node_modules/pngquant-bin/node_modules/bin-build/node_modules/execa/index.js:231:11)

at <anonymous>

at process._tickCallback (internal/process/next_tick.js:188:7)

/var/www/html

├── autoprefixer@7.2.6 extraneous

├─┬ axios@0.16.2

│ ├─┬ follow-redirects@1.9.0

│ │ └─┬ debug@3.2.6

│ │ └── ms@2.1.2

│ └── is-buffer@1.1.6

├── babel-loader@7.1.5 extraneous

├── babel-plugin-transform-object-rest-spread@6.26.0 extraneous

├── babel-plugin-transform-runtime@6.23.0 extraneous

├── babel-preset-env@1.7.0 extraneous

├── bootstrap-sass@3.4.1

├── chokidar@1.7.0 extraneous

├── concatenate@0.0.2 extraneous

├─┬ cross-env@5.2.1

│ └─┬ cross-spawn@6.0.5

│ ├── semver@5.7.1

│ └─┬ which@1.3.1

│ └── isexe@2.0.0

├── css-loader@0.28.11 extraneous

├── dotenv@4.0.0 extraneous

├── dotenv-expand@4.2.0 extraneous

├── extract-text-webpack-plugin@3.0.2 extraneous

├── file-loader@0.11.2 extraneous

├── friendly-errors-webpack-plugin@1.7.0 extraneous

├── fs-extra@3.0.1 extraneous

├── html-loader@0.4.5 extraneous

├── imagemin@5.3.1 extraneous

├── imagemin-gifsicle@5.2.0 extraneous

├── imagemin-mozjpeg@7.0.0 extraneous

├── imagemin-optipng@5.2.1 extraneous

├── imagemin-svgo@6.0.0 extraneous

├── jquery@3.4.1

├── lodash@4.17.15

├── md5@2.2.1 extraneous

├── node-sass@4.12.0 extraneous

├── postcss-loader@2.1.6 extraneous

├── resolve-url-loader@2.3.2 extraneous

├── sass-loader@6.0.7 extraneous

├── style-loader@0.18.2 extraneous

├── uglifyjs-webpack-plugin@1.3.0 extraneous

├── vue@2.6.10

├── vue-loader@13.7.3 extraneous

├── vue-template-compiler@2.6.10 extraneous

├── webpack@3.12.0 extraneous

├── webpack-chunk-hash@0.4.0 extraneous

├── webpack-dev-server@2.11.5 extraneous

├── webpack-merge@4.2.2 extraneous

└── webpack-notifier@1.8.0 extraneous

npm WARN optional Skipping failed optional dependency /chokidar/fsevents:

npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.9

npm WARN optional Skipping failed optional dependency /watchpack/chokidar/fsevents:

npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.9

npm WARN optional Skipping failed optional dependency /webpack-dev-server/chokidar/fsevents:

npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.9

npm WARN ajv-keywords@3.4.1 requires a peer of ajv@^6.9.1 but none was installed.

npm ERR! Linux 5.0.0-29-generic

npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install"

npm ERR! node v8.10.0

npm ERR! npm v3.5.2

npm ERR! code ELIFECYCLE

npm ERR! pngquant-bin@4.0.0 postinstall: `node lib/install.js`

npm ERR! Exit status 1

npm ERR!

npm ERR! Failed at the pngquant-bin@4.0.0 postinstall script 'node lib/install.js'.

npm ERR! Make sure you have the latest version of node.js and npm installed.

npm ERR! If you do, this is most likely a problem with the pngquant-bin package,

npm ERR! not with npm itself.

npm ERR! Tell the author that this fails on your system:

npm ERR! node lib/install.js

npm ERR! You can get information on how to open an issue for this project with:

npm ERR! npm bugs pngquant-bin

npm ERR! Or if that isn't available, you can get their info via:

npm ERR! npm owner ls pngquant-bin

npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:

npm ERR! /var/www/html/npm-debug.log

---------- Добавлено 29.09.2019 в 10:25 ----------

npm install --save-dev cross-env

- is-windows@1.0.1 node_modules/is-windows

/var/www/html

└─┬ cross-env@5.2.1

└─┬ cross-spawn@6.0.5

├── nice-try@1.0.5

└── semver@5.7.1

npm WARN optional Skipping failed optional dependency /chokidar/fsevents:

npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.9

S
На сайте с 30.09.2016
Offline
459
#8

Очень познавательно. ТС упражняется в копипасте. Уже освоил 2 операции: Ctrl+C и Ctrl+V.

Авторизуйтесь или зарегистрируйтесь, чтобы оставить комментарий