Помогите обновить PHP до 7 версии

12
А
На сайте с 27.08.2013
Offline
98
2940

Добрый вечер коллеги. Решил запустить новый проект и захотел на этот раз поставить PHP 7. Однако что-то пошло не так. В итоге обновил php c 5.3 до 5.6. гугл не помог или я криворукий. Стоит centos 6.

LEOnidUKG
На сайте с 25.11.2006
Offline
1551
#1

Эм... в смысле у вас сервер без панели и вы просто хотите установить PHP7?

✅ Трастовых площадок под размещение статей и ссылок. Опыт 12 лет! ( https://searchengines.guru/ru/forum/675690 ) ⭐ Купить вечные трастовые ссылки для сайта ( https://getmanylinks.ru/?srh ) ⭐ Ускорение ваших сайтов (WP, Opencart и др.) + Настройка сервера ( https://searchengines.guru/ru/forum/997205 )
А
На сайте с 27.08.2013
Offline
98
#2

ISP manager 4 lite

LEOnidUKG
На сайте с 25.11.2006
Offline
1551
#3

У вас отдельный сервер под новый проект или тот же?

Оптимизайка
На сайте с 11.03.2012
Offline
396
#4
Айратиус:
Стоит centos 6.

Надо использовать дополнительный репозиторий, например remi (удобнее всего): https://www.tecmint.com/install-php-7-in-centos-6/

или официальный способ через software collections (imho сделано через задницу): https://www.softwarecollections.org/en/scls/rhscl/rh-php72/

⭐ BotGuard (https://botguard.net) ⭐ — защита вашего сайта от вредоносных ботов, воровства контента, клонирования, спама и хакерских атак!
А
На сайте с 27.08.2013
Offline
98
#5
LEOnidUKG:
У вас отдельный сервер под новый проект или тот же?

В этот раз взял отдельный сервер. И на нем хочу все сделать по-человечески. Старые проекты работают на более позднем PHP и пока норм.

---------- Добавлено 14.04.2019 в 22:16 ----------

Оптимизайка:
Надо использовать дополнительный репозиторий, например remi (удобнее всего): https://www.tecmint.com/install-php-7-in-centos-6/
или официальный способ через software collections (imho сделано через задницу): https://www.softwarecollections.org/en/scls/rhscl/rh-php72/

Оптимизайка, можно прям по порядку пожалуйста))) Какие команды вводить? Уже все перепробовал.

LEOnidUKG
На сайте с 25.11.2006
Offline
1551
#6
Айратиус:
В этот раз взял отдельный сервер. И на нем хочу все сделать по-человечески. Старые проекты работают на более позднем PHP и пока норм.

Если отдельный сервер, то почему не centos 7 последняя и панель не ISP5 в которой всё есть из коробки 😕

А
На сайте с 27.08.2013
Offline
98
#7
LEOnidUKG:
Если отдельный сервер, то почему не centos 7 последняя и панель не ISP5 в которой всё есть из коробки 😕

Потому что есть вечная лицензия на ISP 4 . А ISP 5 и centos 7 не хотят дружить.

Оптимизайка
На сайте с 11.03.2012
Offline
396
#8
Айратиус:
Какие команды вводить? Уже все перепробовал.

В документах по ссылкам есть все команды, которые надо вводить и скриншоты и инструкции. Что конкретно не работает, спрашивайте тут.

---------- Добавлено 14.04.2019 в 21:19 ----------

Айратиус:
ISP 5 и centos 7 не хотят дружить.

ISP не нужен, а у centos 6 официальная поддержка заканчивается, если я ничего не путаю, в следующем году.

LEOnidUKG
На сайте с 25.11.2006
Offline
1551
#9
Айратиус:
А ISP 5 и centos 7 не хотят дружить.

Вы что-то путаете:

https://docs.ispsystem.ru/ispmanager-lite/ustanovka-ispmanager/podgotovka-k-ustanovke-paneli-upravleniya

Программные требования
Поддерживаемые операционные системы (ОС) с архитектурой x64:

CentOS 7 (рекомендуем);
А
На сайте с 27.08.2013
Offline
98
#10

1) rpm -Uvh https://mirror.webtatic.com/yum/el6/latest.rpm

2) yum update -y

В ответ вышло

Error: Package: php-7.0.33-7.el7.remi.x86_64 (remi-php70)

Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Error: Package: php-xml-7.0.33-7.el7.remi.x86_64 (remi-php70)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-pecl-zip-1.15.4-1.el7.remi.7.0.x86_64 (remi-php70)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-tidy-7.0.33-7.el7.remi.x86_64 (remi-php70)
Requires: libtidy.so.5()(64bit)
Error: Package: php-tidy-7.0.33-7.el7.remi.x86_64 (remi-php70)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-bcmath-7.0.33-7.el7.remi.x86_64 (remi-php70)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-mbstring-7.0.33-7.el7.remi.x86_64 (remi-php70)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-cli-7.0.33-7.el7.remi.x86_64 (remi-php70)
Requires: libpcre.so.1()(64bit)
Error: Package: php-common-7.0.33-7.el7.remi.x86_64 (remi-php70)
Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-xml-7.0.33-7.el7.remi.x86_64 (remi-php70)
Requires: libxml2.so.2(LIBXML2_2.9.0)(64bit)
Error: Package: php-process-7.0.33-7.el7.remi.x86_64 (remi-php70)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-gd-7.0.33-7.el7.remi.x86_64 (remi-php70)
Requires: libpng15.so.15()(64bit)
Error: Package: php-cli-7.0.33-7.el7.remi.x86_64 (remi-php70)
Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Error: Package: php-cli-7.0.33-7.el7.remi.x86_64 (remi-php70)
Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-mysqlnd-7.0.33-7.el7.remi.x86_64 (remi-php70)
Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-json-7.0.33-7.el7.remi.x86_64 (remi-php70)
Requires: libc.so.6(GLIBC_2.14)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


---------- Добавлено 14.04.2019 в 22:27 ----------

Не-не. Я пробовал раз 5 ставить isp4 на centos7 и всегда выходила ошибка. А потом и на форуме нашел что не дружат они. Ладно. Щас уже стоит centos 6 и так оставлю. Но php обновить нужно.

---------- Добавлено 14.04.2019 в 22:36 ----------

ХЗ ничего не помогает. Очередной мануал https://www.tecmint.com/install-php-7-in-centos-6/ не помог
12

Авторизуйтесь или зарегистрируйтесь, чтобы оставить комментарий