При добавлении fonts.google.com в теме перестают отображаться иконки

denis920
На сайте с 26.02.2009
Offline
151
270

Здравствуйте.

Меняю шрифт темы на Roboto с использованием fonts.google.com, шрифт успешно меняется, но перестают отображаться все иконки в теме.

Подскажите в чем может быть дело и как это можно исправить?

Спасибо.

Сократить ссылку (http://frils.ru) или купить скрипт укорачивателя ссылок
webiumpro
На сайте с 20.03.2017
Offline
38
#1

А какой шрифт вы меняете на roboto?

Копирование лендингов. Разработка на фреймворке сервисов. Создание сайтов (/ru/forum/994418)
denis920
На сайте с 26.02.2009
Offline
151
#2
webiumpro:
А какой шрифт вы меняете на roboto?

Стандартный шрифт Tahoma

webiumpro
На сайте с 20.03.2017
Offline
38
#3

Возможно вы попутно где-то иконочные шрифты отключаете, типа fontawesome и т.п.

Конкретнее не скажу, не видя пациента

denis920
На сайте с 26.02.2009
Offline
151
#4
webiumpro:
Возможно вы попутно где-то иконочные шрифты отключаете, типа fontawesome и т.п.
Конкретнее не скажу, не видя пациента

Я стандартно подключаю добавляя в css

@import url('https://fonts.googleapis.com/css?family=Roboto:400,400i,500,500i,700,700i');

Шрифт отображается, но иконки пропадают

webiumpro
На сайте с 20.03.2017
Offline
38
#5

Сайт показать можете? Гадать можно сколько угодно. И не факт еще, что это проблема происходит из-за подключения гугл-шрифта. «После» не значит «вследствие»

denis920
На сайте с 26.02.2009
Offline
151
#6
webiumpro:
Сайт показать можете? Гадать можно сколько угодно. И не факт еще, что это проблема происходит из-за подключения гугл-шрифта. «После» не значит «вследствие»

Я думаю после, потому что когда я убираю шрифт, оставляю Tahoma, все иконки опять появляются.

S
На сайте с 30.09.2016
Offline
459
#7

Ну так не убирайте Tahoma. Отделяйте мух от котлет. Разделяйте понятия подключения нового шрифта и замены старого на новый.

Отпилю лишнее, прикручу нужное, выправлю кривое. Вытравлю вредителей.

Авторизуйтесь или зарегистрируйтесь, чтобы оставить комментарий