Вернуться   Форум об интернет-маркетинге > >
Ответ
 
Опции темы
Старый 11.09.2019, 09:56   #1
Кандидат наук
 
Регистрация: 27.12.2007
Адрес: Москва
Сообщений: 374
Репутация: 9830
Социальные сети Профиль на Хабрахабре

Question Странная проблема с сетью на арендованном сервере

Арендовал сервер в довольно уважаемой компании. Через некоторое время обнаружил лаги в трафике, которые появлялись каждые 40 минут и длились примерно 4 минуты. Это все фиксировалось при помощи Zabbix из двух датацентров, в одном из которых был арендован сервер.

При обращении в поддержку у меня были запрошены логи и трассировка, что я и предоставил. В логах ничего подозрительного обнаружить не удалось. Трассировка показывала частичные потери пакетов, а при лагах - полные потери.
Прошла уже неделя, разобраться с проблемой не удалось.

Однако недавно я заметил, что лаги появляются после запуска tcpdump для просмотра трафика, и исчезают после перезагрузки ОС (Debian 9.9).

Подскажите, пожалуйста, было ли у кого такое, что посмотреть?
Спасибо!
Александр Фролов вне форума   Ответить с цитированием

Реклама
Старый 11.09.2019, 10:37   #2
WapGraf
Академик
 
Аватар для WapGraf
 
Регистрация: 01.10.2009
Адрес: Болгария
Сообщений: 5,416
Репутация: 199616
Отправить сообщение для WapGraf с помощью Skype™
Социальные сети

По умолчанию Re: Странная проблема с сетью на арендованном сервере

Александр Фролов, если tcpdump пишет в огромные файлы такое вполне возможно.
Если вам нужно писать данные эти, сохраняйте файл чаще и открывайте новый.
__________________
EuroHoster.org - территория быстрых серверов.
2 vCPU / 4 GB RAM / 20 GB SSD / 100 Mbps / панель Plesk / мониторинг доступности - 15.00 EUR
SSL-сертификаты от 4.89 EUR / VPS Нидерланды - 2.50 EUR
WapGraf на форуме   Ответить с цитированием
Старый 11.09.2019, 10:41   #3
Александр Фролов
Кандидат наук
 
Регистрация: 27.12.2007
Адрес: Москва
Сообщений: 374
Репутация: 9830
Социальные сети Профиль на Хабрахабре

ТопикСтартер Re: Странная проблема с сетью на арендованном сервере

WapGraf, спасибо за ответ!

Просто запустил в консоли такую команду:

Код:
tcpdump -n -A -i enp96s0f0 dst xxx.xxx.xxx.xxx and port 80
Смотрел на консоли, кто сканирует сайт, наверное минут 5, не больше.
И трафик там сейчас довольно слабый, порядка 100-200 Kbps.

Интересно, что лаги продолжались и после завершения работы с tcpdump, вплоть до перезагрузки ОС.

Еще мне написали предположение, что интерфейс остался в promiscuous mode и принимает лишние пакеты.
Правда в логах есть такое:

Код:
Sep 10 12:57:35 cs53242 kernel: [99611.449156] device enp96s0f0 entered promiscuous mode
Sep 10 13:01:00 cs53242 kernel: [99816.503087] device enp96s0f0 left promiscuous mode

Последний раз редактировалось Александр Фролов; 11.09.2019 в 11:02..
Александр Фролов вне форума   Ответить с цитированием
Старый 11.09.2019, 15:29   #4
Александр Фролов
Кандидат наук
 
Регистрация: 27.12.2007
Адрес: Москва
Сообщений: 374
Репутация: 9830
Социальные сети Профиль на Хабрахабре

ТопикСтартер Re: Странная проблема с сетью на арендованном сервере

А сейчас запустил tcpdump вначале с -p, потом без -p, и лагов пока не наблюдается. Может не из-за этого?
Александр Фролов вне форума   Ответить с цитированием
Ответ



Опции темы

Быстрый переход


Регистрация Справка Календарь Поддержка Все разделы прочитаны