Вернуться   Форум об интернет-маркетинге > >
Ответ
 
Опции темы
Старый 17.12.2011, 20:20   #21
LiquidStorm
Дипломник
 
Регистрация: 10.08.2010
Адрес: UA
Сообщений: 94
Репутация: 2043

По умолчанию Re: ПО на сервере устарело

Цитата:
Сообщение от myhand Посмотреть сообщение
Если кто-то не умеет CGI-обработчик скофигурировать нормально для виртуалхоста
Кому-то нравится инвалидов клепать, подставляя костыли, а кто-то любит сделать все правильно. Каждому свое, а ТСу удачи в работе
LiquidStorm вне форума   Ответить с цитированием
Сказали спасибо:

Реклама
Старый 17.12.2011, 21:49   #22
Andreyka
Настройщик серверов
 
Аватар для Andreyka
 
Регистрация: 19.02.2005
Адрес: Odessa
Сообщений: 12,726
Репутация: 391399
Отправить сообщение для Andreyka с помощью ICQ Отправить сообщение для Andreyka с помощью AIM Отправить сообщение для Andreyka с помощью MSN Отправить сообщение для Andreyka с помощью Yahoo Отправить сообщение для Andreyka с помощью Skype™ Send Message via Jabber to Andreyka
Социальные сети Профиль на Хабрахабре

По умолчанию Re: ПО на сервере устарело

Еще вариант - нужный софт в джейл и к нему проксировать
__________________
Взлом шифрованной файловой системы LUKS - реальность!
Andreyka вне форума   Ответить с цитированием
Старый 17.12.2011, 22:12   #23
myhand
Академик
 
Регистрация: 16.09.2009
Сообщений: 4,853
Репутация: 138734

По умолчанию Re: ПО на сервере устарело

Цитата:
Сообщение от LiquidStorm Посмотреть сообщение
Кому-то нравится инвалидов клепать, подставляя костыли
Простите, в чем "костыль" использования стандартного функционала PHP?

Вы готовы отвечать за то, что обновление всего нафиг - не поломает ТС другие проекты? Я - нет, потому и не даю заочно советы подобное феерической тупости.
myhand вне форума   Ответить с цитированием
Старый 17.12.2011, 22:50   #24
pupseg
Академик
 
Аватар для pupseg
 
Регистрация: 14.05.2010
Сообщений: 3,681
Репутация: 515397
Отправить сообщение для pupseg с помощью ICQ Отправить сообщение для pupseg с помощью Skype™

По умолчанию Re: ПО на сервере устарело

в общем так.
насколько я понимаю - на лицо проблема стандартная- "Работает годами - я и не трогаю и не вкладываю". Обычно - ежегодно вложения должны возрастать.
ТС, вам уже предложили ряд вариантов.
PS: а в чем проблема на +2300? в сумме? может быть тогда бизнес имеет смысл развить, что бы эти 2300 не ударяли по карману?
__________________
Качественная помощь в обслуживании серверов.
Бесплатных консультаций не даю, не помогаю, не обучаю. Минималка от 100$. Как пропатчить KDE-просьба не спрашивать. Есть форумы и полезные сайты.
pupseg вне форума   Ответить с цитированием
Сказали спасибо:
Старый 18.12.2011, 01:47   #25
V(o)ViK
Профессор
 
Регистрация: 27.07.2008
Сообщений: 680
Репутация: 42944

По умолчанию Re: ПО на сервере устарело

Больше интересно другое, почему до сих пор на вашем сервере стоит релиз, время поддержки которого закончилось 5 лет назад ?
Такое "администрирование" вам и даром не нужно.
V(o)ViK вне форума   Ответить с цитированием
Старый 18.12.2011, 02:21   #26
LiquidStorm
Дипломник
 
Регистрация: 10.08.2010
Адрес: UA
Сообщений: 94
Репутация: 2043

По умолчанию Re: ПО на сервере устарело

Цитата:
Сообщение от myhand Посмотреть сообщение
Простите, в чем "костыль" использования стандартного функционала PHP?

Вы готовы отвечать за то, что обновление всего нафиг - не поломает ТС другие проекты? Я - нет, потому и не даю заочно советы подобное феерической тупости.
Где предложение обновить все? Где make buildworld && make buildkernel ?

Вы предложили заменить стандартный пхп отдельным обработчиком, причем для отдельного модуля (вы написали УРЛ, хотя какой к черту УРЛ, если модуль инклудится при интерпретации основной ЦМС)
https://searchengines.guru/showpost....0&postcount=16

Далее вы пишете про настройку для виртуалхоста... где тут "стандартный функционал пхп", если речь о настройке демона веб-сервера?
https://searchengines.guru/showpost....7&postcount=19

Как-то так ...
LiquidStorm вне форума   Ответить с цитированием
Старый 18.12.2011, 11:17   #27
myhand
Академик
 
Регистрация: 16.09.2009
Сообщений: 4,853
Репутация: 138734

По умолчанию Re: ПО на сервере устарело

Цитата:
Сообщение от LiquidStorm Посмотреть сообщение
Где предложение обновить все?
https://searchengines.guru/showpost....8&postcount=10
Собственно, даже "обновить PHP+mysql" - фактически эквивалентно "обновить все".
Цитата:
Сообщение от LiquidStorm Посмотреть сообщение
Вы предложили заменить стандартный пхп отдельным обработчиком
Да, CGI-интерепретатором. ПХП от этого "нестандартным" не станет - просто для отдельного сайта будет работать своя версия.
Цитата:
Сообщение от LiquidStorm Посмотреть сообщение
причем для отдельного модуля (вы написали УРЛ, хотя какой к черту УРЛ, если модуль инклудится при интерпретации основной ЦМС)
Может он работает для конкретного пути. Я упомянул это как вариант.

Цитата:
Сообщение от LiquidStorm Посмотреть сообщение
Далее вы пишете про настройку для виртуалхоста... где тут "стандартный функционал пхп", если речь о настройке демона веб-сервера?
Работа PHP в качестве CGI-скрипта - стандартный функционал:
http://www.php.net/manual/en/install...ommandline.php

Цитата:
Сообщение от V(o)ViK Посмотреть сообщение
Больше интересно другое, почему до сих пор на вашем сервере стоит релиз, время поддержки которого закончилось 5 лет назад ?
Такое "администрирование" вам и даром не нужно.
Оно типа и есть даром. Давайте за глаза не осуждать людей - ТС ведь не объяснил что входит в услугу администрирования, на каких условиях.
myhand вне форума   Ответить с цитированием
Старый 18.12.2011, 11:37   #28
pupseg
Академик
 
Аватар для pupseg
 
Регистрация: 14.05.2010
Сообщений: 3,681
Репутация: 515397
Отправить сообщение для pupseg с помощью ICQ Отправить сообщение для pupseg с помощью Skype™

По умолчанию Re: ПО на сервере устарело

make buildworld - хорошая идея... но только внутри веток, например с 7.0 на 7.3, у меня успешно обновлялось с 6.0 до 7.0....
но чтото мне подсказывает - что make buildworld на 5.х ----> 8.x завалит сервер окончательно
pupseg вне форума   Ответить с цитированием
Старый 18.12.2011, 12:20   #29
V(o)ViK
Профессор
 
Регистрация: 27.07.2008
Сообщений: 680
Репутация: 42944

По умолчанию Re: ПО на сервере устарело

1. Устанавливаете новый сервер, ставите на него современные версии ПО.
2. Настраиваете в jail версии ПО и настройки максимально приближенные к тому что есть сейчас. Благо в портах есть php 4.x 5.2.x 5.3.x и куча разных апачей и mysql.
3. Выполняете перенос. Все что заводится малой кровью, оставляете на сервере, все что не заводится, переносите в jail и неспешно переводите на последние версии ПО, если в этом есть смысл.

Обновлять с 5.x будет более затратно и не целесообразно.
Цитата:
Сообщение от myhand Посмотреть сообщение
Оно типа и есть даром. Давайте за глаза не осуждать людей - ТС ведь не объяснил что входит в услугу администрирования, на каких условиях.
Да я не осуждаю ) Больше поражает, что оно до сих пор работает ) настраивали изначально явно с пристрастием )
V(o)ViK вне форума   Ответить с цитированием
Старый 18.12.2011, 14:04   #30
myhand
Академик
 
Регистрация: 16.09.2009
Сообщений: 4,853
Репутация: 138734

По умолчанию Re: ПО на сервере устарело

Цитата:
Сообщение от V(o)ViK Посмотреть сообщение
1. 2. 3.
Кому, интересно, вы пишете?
Цитата:
Сообщение от V(o)ViK Посмотреть сообщение
Да я не осуждаю ) Больше поражает, что оно до сих пор работает )
Было бы странно, если б оно перестало работать.
myhand вне форума   Ответить с цитированием
Ответ



Опции темы

Быстрый переход


Регистрация Справка Календарь Поддержка Все разделы прочитаны