Вернуться   Форум об интернет-маркетинге > >
Ответ
 
Опции темы
Старый 16.08.2019, 17:29   #41
SeVlad
Guru-Editor
 
Регистрация: 03.11.2008
Адрес: Donbass
Сообщений: 18,311
Репутация: 1509260

По умолчанию Re: Нормально если вебмастер сделал сайт на wordpress, работающий только на PHP 5.6?

Цитата:
Сообщение от ivan-lev Посмотреть сообщение
А вдруг к завершению проекта появится новая ветка PHP.. как тогда быть?
ВСЕГДА нужно чтобы конечный продукт поддерживал современное ПО.
Но не в коем случае не ограничивался мёртвым.

Цитата:
Сообщение от ivan-lev Посмотреть сообщение
лучше оговорить заранее.. ))
Ещё раз: ни версии ПО ни модели железа заказчика волновать не должны. Это не его епархия.
(Только в специальных случаях, отличных от дефолтных это оговаривается)

Ну у нормальных вебмастеров так во всяком случае.
Цитата:
Сообщение от ivan-lev Посмотреть сообщение
Так вот этот "дефолт" у нас по-разному толкуется.. )))
Это КМК больше упёртость, чем трактовка. Есть современно актуальное ПО, есть разные требования (от HTML до безопасности и передачи данных). Всё.

Хотя да, помятуя топик, где якобы крутые разрабы, но не понимают зачем шифровать пароли - не сильно и удивлён "разным" трактовкам.
__________________
Делаю хорошие сайты хорошим людям. Предпочтение коммерческим направлениям.
Топики помощи с ⓌordPress и основы безопасности сайтов.
*** Помощь\консультации в топиках форума - БЕСПЛАТНО. Через личку - с бюджетом от 150$ ***
SeVlad вне форума   Ответить с цитированием

Реклама
Старый 16.08.2019, 17:31   #42
edogs
Писать: search@ник_тут.ru
 
Аватар для edogs
 
Регистрация: 16.12.2005
Адрес: St.Petersburg, Russia
Сообщений: 8,381
Репутация: 123435
Отправить сообщение для edogs с помощью Skype™

По умолчанию Re: Нормально если вебмастер сделал сайт на wordpress, работающий только на PHP 5.6?

Цитата:
Сообщение от ivan-lev Посмотреть сообщение
Если откинуть WP и несовместимость в пределах темы.. то "переделать под новую версию языка" может быть вполне сравнимо по стоимости с проектом ))
Если брать php версии старше 4.х, то там изменения вплоть до 7.2 по крайней мере достаточно легко отслеживаются и даже исправляются на автомате.
У нас за последние годы много заказов было именно на адаптацию/проверку скриптов с пхп 4 или 5 на 7-ку и по большому счету самый большой гимор был это из-за отключения глобальных GPC и магических кавычек, остальное всё легко и быстро решается.

Что касается версий на которых должно работать - если заказчик не хочет себе морочить голову, но в то же время хочет гарантировать запуск проекта, то проще всего изначально предоставить к хостингу, а последним этапом работы сделать установку проекта на этот хостинг. Это гарантирует с одной стороны заказчику что проект взлетит там, где он хочет. С другой стороны гарантирует исполнителю четкость критериев работает или нет. Опять же это гарантирует сис.админу спокойный сон, т.к. не придется что-то докручивать.
__________________
Разработка крупных и средних проектов. Можно с криптой. Разумные цены. Хорошее качество. Адекватный подход.
edogs вне форума   Ответить с цитированием
Старый 16.08.2019, 17:36   #43
SeVlad
Guru-Editor
 
Регистрация: 03.11.2008
Адрес: Donbass
Сообщений: 18,311
Репутация: 1509260

По умолчанию Re: Нормально если вебмастер сделал сайт на wordpress, работающий только на PHP 5.6?

Цитата:
Сообщение от ivan-lev Посмотреть сообщение
И про "популярность".. если задачу удобнее решить "непопоулярным" инструментом, то почему нет (если, конечно, в ТЗ не было).. )
Тут я воще-то говорил про популярность ПО - начиная от браузеров и заканчивая вебсерверами.
Если разраб скажет "у меня на моём "супервебсервере" работает, а вы не сказали что должно работать на аппаче" или "в моём супербраузере ок, и пофик что в ФФ невозможно сделать заказ" - это говнюк, а не разраб.
SeVlad вне форума   Ответить с цитированием
Старый 16.08.2019, 17:37   #44
edogs
Писать: search@ник_тут.ru
 
Аватар для edogs
 
Регистрация: 16.12.2005
Адрес: St.Petersburg, Russia
Сообщений: 8,381
Репутация: 123435
Отправить сообщение для edogs с помощью Skype™

По умолчанию Re: Нормально если вебмастер сделал сайт на wordpress, работающий только на PHP 5.6?

Цитата:
Сообщение от SeVlad Посмотреть сообщение
ВСЕГДА нужно чтобы конечный продукт поддерживал современное ПО.
Понятие "современное ПО" слишком широкое, это фраза такая же фигня как "сайт должен работать очень быстро" и "верстка должна отображаться на любых устройствах одинаково".
Из последнего - затачивали заказчику сайт на производительность, два дня объясняли что точить производительность для mysql и mariadb это разные вещи, т.к. запросы некоторые по разному оптимизируются и разница может быть драматической. А ведь то и другое - современное ПО, которое у большинства заказчиков вообще в голове не отличается.

Цитата:
Сообщение от SeVlad Посмотреть сообщение
Ещё раз: ни версии ПО ни модели железа заказчика волновать не должны. Это не его епархия.
Должны. Никакое ПО не работает в вакууме, условия работы это неотъемлимая часть задания. Так же как водитель должен знать для какого топлива он покупает автомобиль и не удивляться что он троит на 98 или глохнет на дизеле.
Если заказчик хочет что бы это его вообще не волновало, он либо берет хостинг у прогера, либо поручает своему сис.админу этим заняться. Или в примере с авто - ездит на такси или с личным водителем.

Если же заказчик не указал версию ПО, то разработчик может сделать на на чем угодно. Может даже сделать сайт на c#, если заказчик тупанул и не указал php в требованиях. Со стороны разработчика непрофессионально не спросить на чем оно должно работать, но не более того. Со стороны заказчика в свою очереь тупо не указать на чем оно должно работать.

Вы вот топите за то, что все должно работать на последних 7.х php - так это Вы просто не сталкивались с заказчиками у которых "по умолчанию" все должно работать начиная от php 4 и netscape. А ведь у них та же логика что и у Вас тут, мол не дело заказчика думать что там за ПО, он заказал - а разработчик должен сделать что бы оно работало ну прям везде - даже на калькуляторе из 70-тых.
edogs вне форума   Ответить с цитированием
Сказали спасибо:
Старый 16.08.2019, 17:52   #45
SeVlad
Guru-Editor
 
Регистрация: 03.11.2008
Адрес: Donbass
Сообщений: 18,311
Репутация: 1509260

По умолчанию Re: Нормально если вебмастер сделал сайт на wordpress, работающий только на PHP 5.6?

Цитата:
Сообщение от edogs Посмотреть сообщение
Понятие "современное ПО" слишком широкое, это фраза такая же фигня как "сайт должен работать очень быстро" и "верстка должна отображаться на любых устройствах одинаково".
Ничего особо широкого тут нет - не мёртвое и не экзотика*.
Это так же не требует оговаривания как и "сайт не должен тормозить".


*На сегодня: php из этого списка, аппач или нжинкс, отображаться в актуальных хроме и ФФ, включая мобильные. Вот сафари и пр яблокопротукты возможно уже можно и отдельно проговорить, но нормальный вебмастер не создаст из этого проблему и конфликт.
Цитата:
Сообщение от edogs Посмотреть сообщение
Должны
Ипите мозги закачикам ипите..
SeVlad вне форума   Ответить с цитированием
Старый 16.08.2019, 18:31   #46
_SP_
Академик
 
Регистрация: 24.03.2008
Адрес: MSK
Сообщений: 3,774
Репутация: 374415

По умолчанию Re: Нормально если вебмастер сделал сайт на wordpress, работающий только на PHP 5.6?

Цитата:
Сообщение от SeVlad Посмотреть сообщение
ВСЕГДА нужно чтобы конечный продукт поддерживал современное ПО.
Но не в коем случае не ограничивался мёртвым.
Блажь и влажные фантазии.

Конечный продукт должен поддерживать версии ПО указанные в SRS...

И очень часто, в нормальных, серьезных проектах, это именно устаревшее ПО.
Просто потому, что некоторое ПО устаревает быстрее, чем проекты бывают завершены, и уж заведомо быстрее, чем жизненный цикл нормальных проектов.

Это особенно остро работает... с windows.
Некоторые продукты до сих пор под xp работают, и никто их портировать под вин10 не берется.
Ибо дорого и тупо. (переход xp->win7 тот еще кошмар, к примеру... )
_SP_ вне форума   Ответить с цитированием
Сказали спасибо:
Старый 16.08.2019, 21:25   #47
edogs
Писать: search@ник_тут.ru
 
Аватар для edogs
 
Регистрация: 16.12.2005
Адрес: St.Petersburg, Russia
Сообщений: 8,381
Репутация: 123435
Отправить сообщение для edogs с помощью Skype™

По умолчанию Re: Нормально если вебмастер сделал сайт на wordpress, работающий только на PHP 5.6?

Цитата:
Сообщение от SeVlad Посмотреть сообщение
Ничего особо широкого тут нет - не мёртвое и не экзотика*.
Это так же не требует оговаривания как и "сайт не должен тормозить".
Это так же требует оговаривания как и "сайт не должен тормозить". Потому что иначе Вы рано или поздно столкнетесь с предьявой "сайт тормозит" и будете обтекать, потому что понятия "тормозит" у Вас и у заказчика будут разные.

Цитата:
Сообщение от SeVlad Посмотреть сообщение
*На сегодня: php из этого списка, аппач или нжинкс, отображаться в актуальных хроме и ФФ, включая мобильные. Вот сафари и пр яблокопротукты возможно уже можно и отдельно проговорить, но нормальный вебмастер не создаст из этого проблему и конфликт.

Ипите мозги закачикам ипите..
Так ипете как раз Вы. Мы до начала работ оговариваем где и как что должно работать, в том числе в количественных и цифровых выражениях.
А у Вас невнятное бормотание "не тормозит, не экзотика, актуальные", которое можно трактовать как угодно, вплоть до того, что Ваш софт может и на 7.1 не заводиться (не говоря уже о 5.6), т.к. с Вашей точки зрения "это не актуально, сеня"© А если заказчик с Вами не согласен (и не важно что у него есть объективные причины), то он с Вашей точки зрения дурак, который должен поставить всё самое новое, потому что Ваш модный софт под старое не умеет.
edogs вне форума   Ответить с цитированием
Старый 16.08.2019, 21:30   #48
WCREATOR
Аспирант
 
Регистрация: 27.04.2016
Сообщений: 192
Репутация: -6515

По умолчанию Re: Нормально если вебмастер сделал сайт на wordpress, работающий только на PHP 5.6?

Цитата:
Сообщение от edogs Посмотреть сообщение
потому что Ваш модный софт под старое не умеет.
модный софт? это что? последняя версия, это не мода, это последняя версия (7.0-7.3)
__________________
сайты на OVH
домены на Gandi.net, GoDaddy.com, Name.am, Register.it
WCREATOR вне форума   Ответить с цитированием
Старый 16.08.2019, 21:45   #49
SeVlad
Guru-Editor
 
Регистрация: 03.11.2008
Адрес: Donbass
Сообщений: 18,311
Репутация: 1509260

По умолчанию Re: Нормально если вебмастер сделал сайт на wordpress, работающий только на PHP 5.6?

Цитата:
Сообщение от _SP_ Посмотреть сообщение
в SRS...
В GSD, WEDS, и ещё в SAR.
А какие "страшные" аббревиатуры ты ещё знаешь?

Цитата:
Сообщение от _SP_ Посмотреть сообщение
серьезных проектах.. портировать
За 20-50 тыщ-то?
Вы с едогсами как всегда лепете херню на своей волне, не пытаясь вникнуть в суть топика.

Еще раз для альтернативно одарённых: речь о НОВЫХ продуктах, а не о переделке древних. Не андестен никак, не?

И оставьте эти сказки про "серьёзные проекты" для тех кто вас не знает...
У вас в головах нет даже понимания про необходимость шифрования паролей, проблему топика не в стоянии осилить, а теперь, оказывается выпускаете продукты на трупах.
Сказочники, такие сказочники. Зато в носками индпошива. Или тоже сказки? Да конечно сказки..
Цитата:
Сообщение от edogs Посмотреть сообщение
Так ипете как раз Вы. Мы до начала работ оговариваем где и как что должно работать, в том числе в количественных и цифровых выражениях.
А я вот не спрашиваю ни тип процессора ни версию ПХП. Я выдаю готовый продукт, работающий на любом нормальном современном хостинге.
Так кто ипёт-то заказчикам мозги?
(не, я тоже задаю кучу вопросов, но только по делу)

Последний раз редактировалось SeVlad; 16.08.2019 в 22:28.. Причина: орфо
SeVlad вне форума   Ответить с цитированием
Старый 16.08.2019, 22:08   #50
edogs
Писать: search@ник_тут.ru
 
Аватар для edogs
 
Регистрация: 16.12.2005
Адрес: St.Petersburg, Russia
Сообщений: 8,381
Репутация: 123435
Отправить сообщение для edogs с помощью Skype™

По умолчанию Re: Нормально если вебмастер сделал сайт на wordpress, работающий только на PHP 5.6?

Цитата:
Сообщение от SeVlad Посмотреть сообщение
А я вот не спрашиваю версию ПХП. Я выдаю готовый продукт, работающий на любом нормальном современном хостинге.
Так кто ипёт-то заказчикам мозги?
Вы ипете. Потому что когда Ваш продукт у заказчика не заводится, то начинается демонстрация ЧСВ, мол раз не завелось, то это не продукт так себе что не совместим и не исполнитель так себе что не спросил на чем оно должно работать,, а это заказчик дурак, потому что хостинг у него ненормальный и несовременный. А всего делов было версию пхп спросить исполнителю или сказать заказчику.

Цитата:
Сообщение от SeVlad Посмотреть сообщение
Вы с егодгсами как всегда лепете херню на своей волне, не пытаясь вникая в суть топика.
Мы до Вас пытаемся донести ту простую мысль, что прежде чем выбирать версию пхп под которую писать - надо спросить про нее у заказчика. А заказчику если ему нужно что бы работало где-то конкретно - тоже надо не в молчанку играть, а заранее это оговорить.
edogs вне форума   Ответить с цитированием
Ответ



Опции темы

Быстрый переход


Регистрация Справка Календарь Поддержка Все разделы прочитаны